Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 560970

Summary: x11-drivers/xf86-input-libinput-0.14.0: compile failure
Product: Gentoo Linux Reporter: Stijn Tintel <stijn+gentoo>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: normal CC: kris, toralf, zmedico
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 559062    
Attachments: build.log
Patch with fix as suggested by Jeremi Piotrowski

Description Stijn Tintel 2015-09-21 06:02:05 UTC
xf86-video-input 0.14.0 fails to compile:

/var/tmp/portage/x11-drivers/xf86-input-libinput-0.14.0/work/xf86-input-libinput-0.14.0/src/xf86libinput.c:934:3: error: implicit declaration of function 'xf86Msg' [-Werror=implicit-function-declaration]
   xf86Msg(X_ERROR, "Failed to look up path '%s'\n", path);
   ^


Reproducible: Always

Steps to Reproduce:
1. echo "x11-drivers/xf86-input-libinput" > /etc/portage/package.accept_keywords 
2. emerge xf86-video-input
Actual Results:  
Compile fails

Expected Results:  
Compile should not fail

Portage 2.2.20.1 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-4.8.5, glibc-2.20-r2, 4.2.0-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.2.0-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-5500U_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:     8136236 total,     89448 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 21 Sep 2015 05:00:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.8.5::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

tox-overlay
    location: /var/lib/layman/tox-overlay
    masters: gentoo
    priority: 0

gamarouns
    location: /var/lib/layman/gamarouns
    masters: gentoo
    priority: 1

kde
    location: /var/lib/layman/kde
    masters: gentoo
    priority: 2

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 3

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -mavx2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mavx2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi adns aes alsa amd64 avx avx2 berkdb bluetooth branding btrfs bzip2 cairo cdda cdr cli cracklib crypt cryptsetup cups cxx dbus declarative device-mapper dri dts dvd dvdr emboss encode exif fam firefox flac fma3 fortran gdbm geoip gif glamor gpm gtk highdpi iconv ipv6 jpeg kde kipi lcms ldap libnotify lzma mad mmx mmxext mng modules mp3 mp4 mpeg mtp multilib ncurses networkmanager nls nptl nsplugin ogg opengl openmp pam pango pcre pdf phonon plasma png policykit popcnt ppds pulseaudio qml qt3support qt5 rdrand readline samba sdl seccomp session smp spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd tiff touchpad truetype udev udisks unicode upower usb v4l vaapi vim-syntax vorbis vpx webp widgets wifi wxwidgets x264 x265 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev keyboard libinput mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB en_US nl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="dummy intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Stijn Tintel 2015-09-21 06:02:56 UTC
Created attachment 412398 [details]
build.log
Comment 2 Jeroen Roovers gentoo-dev 2015-09-21 06:24:20 UTC

*** This bug has been marked as a duplicate of bug 555284 ***
Comment 3 Jeremi Piotrowski 2015-09-21 08:24:06 UTC
This is *not* a duplicate of bug 555284, I have all the *proto packages mentioned in _that_ bug installed and _this_ bug is still present.

This looks to me like an upstream bug, caused by a missing "include". The fix is adding

    #include <xf86.h>

to `src/xf86libinput.h`. The header is part of x11-base/xorg-server.
Comment 4 Stijn Tintel 2015-09-22 08:22:17 UTC
(In reply to Jeremi Piotrowski from comment #3)
> This is *not* a duplicate of bug 555284, I have all the *proto packages
> mentioned in _that_ bug installed and _this_ bug is still present.
Same here. All packages mentioned in #555284 are installed and also still running into this issue. Versions 0.6.0, 0.12.0 and 0.13.0 previously compiled fine on this system.
> 
> This looks to me like an upstream bug, caused by a missing "include". The
> fix is adding
> 
>     #include <xf86.h>
> 
> to `src/xf86libinput.h`. The header is part of x11-base/xorg-server.
This does indeed fix the compile. Thanks!
Comment 5 Stijn Tintel 2015-09-22 08:24:24 UTC
Created attachment 412512 [details, diff]
Patch with fix as suggested by  Jeremi Piotrowski
Comment 6 Zac Medico gentoo-dev 2015-09-24 00:57:44 UTC
(In reply to Stijn Tintel from comment #5)
> Created attachment 412512 [details, diff] [details, diff]
> Patch with fix as suggested by  Jeremi Piotrowski

This patch worked for me.

The ability to reproduce this bug is dependent on the installed versions of headers. You'll be able to reproduce it only if xf86.h doesn't happen to be included indirectly via the existing includes.
Comment 7 Stanislav Ochotnicky (RETIRED) gentoo-dev 2015-10-16 00:19:07 UTC
FYI I posted the patch on upstream mailing list:
http://lists.freedesktop.org/archives/wayland-devel/2015-October/024898.html
Comment 8 Austin English (RETIRED) gentoo-dev 2015-11-03 21:21:55 UTC
Still present in 0.15.0.
Comment 9 Chí-Thanh Christopher Nguyễn gentoo-dev 2016-04-07 16:21:41 UTC
*** Bug 570700 has been marked as a duplicate of this bug. ***
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2016-04-07 16:28:51 UTC
As upstream ignored the patch so far, I added it to xf86-input-libinput-0.18.0
Comment 11 Thomas Deutschmann gentoo-dev Security 2016-06-30 12:07:47 UTC
*** Bug 587202 has been marked as a duplicate of this bug. ***
Comment 12 Thomas Deutschmann gentoo-dev Security 2016-06-30 12:10:30 UTC
Re-opening. Like reported in bug 587202 (now marked as duplicate of this bug) the patch added by chithanh in comment #10 is only in the repository but no ebuild is applying the patch.
Comment 14 Chí-Thanh Christopher Nguyễn gentoo-dev 2016-07-03 23:14:22 UTC
@mrueg please revert your change per comment 13

However as upstream's 0.19.0 includes this patch, this bug is considered fixed.