Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 555284 - x11-drivers/xf86-input-libinput has missing proto deps
Summary: x11-drivers/xf86-input-libinput has missing proto deps
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on: 379545
Blocks: 553500
  Show dependency tree
 
Reported: 2015-07-18 18:09 UTC by Tobias Klausmann
Modified: 2018-04-27 17:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann gentoo-dev 2015-07-18 18:09:14 UTC
#Subject is currently not depending on these:

x11-misc/util-macros
x11-proto/videoproto
x11-proto/scrnsaverproto
x11-proto/resourceproto
x11-proto/xf86driproto
x11-proto/glproto
x11-proto/dri2proto
x11-proto/dri3proto
x11-proto/presentproto
x11-proto/xineramaproto

Usually, other parts of the X11 stack pull these in, but during testing for XFCE stabilization (see blocker), I found that these were not DEP'd on, but configure complained about there absence (tested with 0.6.0, but I suspect the other versions need this too).
Comment 1 Jeroen Roovers gentoo-dev 2015-09-21 06:24:20 UTC
*** Bug 560970 has been marked as a duplicate of this bug. ***
Comment 2 Matt Turner gentoo-dev 2018-04-27 17:52:18 UTC
With x11-base/xorg-proto it is not possible for this to occur anymore.