Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 440872

Summary: Xorg stabilization list for November
Product: Gentoo Linux Reporter: Chí-Thanh Christopher Nguyễn <chithanh>
Component: [OLD] Keywording and StabilizationAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: enhancement CC: axiator, flo, nikoli, pacho, phajdan.jr, poncho
Priority: Normal Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 414295, 435682, 438246, 440876, 443292, 443508, 447152, 448570, 448606, 448608    
Bug Blocks: 443080, 445764, 448562    
Attachments: x11_stable.list v1
x11_stable.list v2
x11_stable.list v3
x11_stable.list v4
x11_stable.list v5

Description Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-02 00:19:54 UTC
Created attachment 328010 [details]
x11_stable.list v1

This bug is for stabilization of x11 packages.

No talking here, please. If you find a regression that should block stabilization: report a separate bug and make it block this bug.

To generate the keywords list for your arch, run
# awk '/YOURARCHHERE/ {print "="$1}' x11_stable.list > x11_stable.keywords
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-02 00:39:45 UTC
*** Bug 439714 has been marked as a duplicate of this bug. ***
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-02 00:40:01 UTC
*** Bug 429230 has been marked as a duplicate of this bug. ***
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-02 00:40:18 UTC
*** Bug 428838 has been marked as a duplicate of this bug. ***
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-11 01:04:30 UTC
Created attachment 329162 [details]
x11_stable.list v2

updated xorg-server, x11-drivers and pixman stabilization targets, added glamor
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-14 13:16:58 UTC
Created attachment 329532 [details]
x11_stable.list v3

* Add glu and xf86-input-synaptics to stabilization list
* Update xf86-video-intel stabilization target
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-11-15 11:44:45 UTC
Created attachment 329600 [details]
x11_stable.list v4

* Drop vdpau-video (handled in bug 443292)
* Revise xcb-proto stabilization target to 1.8
Comment 7 Agostino Sarubbo gentoo-dev 2012-11-16 16:44:42 UTC
amd64 stable
Comment 8 Agostino Sarubbo gentoo-dev 2012-11-18 12:27:50 UTC
x86 stable
Comment 9 Brent Baude (RETIRED) gentoo-dev 2012-11-28 21:46:36 UTC
ppc done
Comment 10 Agostino Sarubbo gentoo-dev 2012-12-08 17:18:22 UTC
ppc64 stable
Comment 11 Markus Meier gentoo-dev 2012-12-17 20:39:01 UTC
arm stable
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-25 16:54:33 UTC
Created attachment 333314 [details]
x11_stable.list v5

Updated stabilization list for regression and other bug fixes that have been reported since xorg-server-1.13 went stable.
Comment 13 Agostino Sarubbo gentoo-dev 2012-12-28 11:44:35 UTC
ia64 stable
Comment 14 Agostino Sarubbo gentoo-dev 2012-12-28 17:46:24 UTC
sparc stable
Comment 15 Toralf Förster gentoo-dev 2012-12-28 18:53:46 UTC
(In reply to comment #8)
> x86 stable

b/c the list was updated to (at least) mesa-9.0.1 /me wonders whether this package should be marked as stable for x86 ?
Comment 16 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-28 23:40:27 UTC
Please, no talking here. And look at bug 448562.
Comment 17 Agostino Sarubbo gentoo-dev 2012-12-30 14:57:05 UTC
alpha stable
Comment 18 Raúl Porcel (RETIRED) gentoo-dev 2013-01-01 19:13:46 UTC
s390/sh stable
Comment 19 Jeroen Roovers (RETIRED) gentoo-dev 2013-01-04 17:42:55 UTC
ARM still needs to stabilise x11-base//xorg-server-1.13.1.
Comment 20 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-04 17:45:16 UTC
(In reply to comment #19)
That is being handled in bug 448562.
Comment 21 Jeroen Roovers (RETIRED) gentoo-dev 2013-01-04 18:05:26 UTC
OK, this appears to be done, then.