Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447152 - Various x11-drivers/xf86-video-* fails on IA64 with: error: impossible register constraint in 'asm'
Summary: Various x11-drivers/xf86-video-* fails on IA64 with: error: impossible regist...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: IA64 Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on:
Blocks: 440872 475480
  Show dependency tree
Reported: 2012-12-13 19:46 UTC by Agostino Sarubbo
Modified: 2014-10-03 12:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (xf86-video-apm-1.2.5:20121213-192117.log,15.19 KB, text/plain)
2012-12-13 19:46 UTC, Agostino Sarubbo
fix_inx_outx.patch (fix_inx_outx.patch,1.70 KB, patch)
2013-01-09 21:54 UTC, Chí-Thanh Christopher Nguyễn
Details | Diff
unloadsubmodule.patch (unloadsubmodule.patch,1.34 KB, patch)
2013-01-09 21:55 UTC, Chí-Thanh Christopher Nguyễn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2012-12-13 19:46:03 UTC
Created attachment 332244 [details]

I get failures from x11-drivers/xf86-video-* packages with the error:

error: impossible register constraint in 'asm'

I'm attaching a full build log. CC'ing toolchain as per chithanh request.

Portage (default/linux/ia64/10.0, gcc-4.5.4, glibc-2.15-r3, 2.6.34-gentoo-r11 ia64)                                                                                        
System uname: Linux-2.6.34-gentoo-r11-ia64-32-with-gentoo-2.1                                                                                                                       
Timestamp of tree: Tue, 11 Dec 2012 19:00:01 +0000                                                                                                                                  
app-shells/bash:          4.2_p37                                                                                                                                                   
dev-lang/python:          2.7.3-r2, 3.2.3                                                                                                                                           
dev-util/cmake:           2.8.9                                                                                                                                                     
dev-util/pkgconfig:       0.27.1                                                                                                                                                    
sys-apps/baselayout:      2.1-r1                                                                                                                                                    
sys-apps/sandbox:         2.5                                                                                                                                                       
sys-devel/autoconf:       2.68                                                                                                                                                      
sys-devel/automake:       1.11.6                                                                                                                                                    
sys-devel/binutils:       2.22-r1                                                                                                                                                   
sys-devel/gcc:            4.5.4                                                                                                                                                     
sys-devel/gcc-config:     1.7.3                                                                                                                                                     
sys-devel/libtool:        2.4-r1                                                                                                                                                    
sys-devel/make:           3.82-r3                                                                                                                                                   
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)                                                                                                                               
sys-libs/glibc:           2.15-r3                                                                                                                                                   
Repositories: gentoo                                                                                                                                                                
CFLAGS="-O2 -pipe -mtune=itanium2"                                                                                                                                                  
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"                                                                                                    
CXXFLAGS="-O2 -pipe -mtune=itanium2"                                                                                                                                                
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm ia64 iconv ipv6 modules mudflap ncurses nls nptl openmp pam pcre pppd readline session ssl tcpd unicode zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="am fil zh af ca cs da de el es et gl hu nb nl pl pt ro ru sk sl sv uk bg cy en eo fo ga he id ku lt lv mk ms nn sw tn zu ja zh_TW en_GB pt_BR ko zh_CN ar en_CA fi kk oc sr tr fa wa nds as be bn bn_BD bn_IN en_US es_AR es_CL es_ES es_MX eu fy fy_NL ga_IE gu gu_IN hi hi_IN is ka kn ml mr nn_NO or pa pa_IN pt_PT rm si sq sv_SE ta ta_LK te th vi ast dz km my om sh ug uz ca@valencia sr@ijekavian sr@ijekavianlatin sr@latin csb hne mai se es_LA fr_CA zh_HK br la no es_CR et_EE sr_CS bo hsb hy mn sr@Latn lb ne bs tg uz@cyrillic xh be_BY brx ca_XV dgo en_ZA gd kok ks ky lo mni nr ns pap ps rw sa_IN sat sd ss st sw_TZ ti ts ve mt ia az me tl ak hy_AM lg nso son ur_PK it fr nb nb_NO hr nan ur tk cs_CZ da_DK de_1901 de_CH en_AU lt_LT pl_PL sa sk_SK th_TH ta_IN tt sco ha mi ven ar_SY el_GR ro_RO ru_RU sl_SI uk_UA vi_VN ar_SY te_IN de_DE es_VE fa_IR fr_FR hu_HU id_ID it_IT ja_JP ka_GE nl_NL sr_BA sr_RS ca_ES fi_FI he_IL jv ru_gold yi eu_ES" PHP_TARGETS="php5-3 php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU"
USE_PYTHON="2.7 3.2"
Comment 1 SpanKY gentoo-dev 2012-12-14 07:31:56 UTC
looks like a simple bug in the xorg server's compiler.h.  that file looks like a huge pile of crap, but i think this one line fix should make it work for ia64 again:

-#if !defined(FAKEIT) && !defined(__mc68000__) && !defined(__arm__) && !defined(__sh__) && !defined(__hppa__) && !defined(__s390__) && !defined(__m32r__)
+#if !defined(FAKEIT) && !defined(__mc68000__) && !defined(__arm__) && !defined(__sh__) && !defined(__hppa__) && !defined(__s390__) && !defined(__m32r__) && !defined(__ia64__)

(just add a !__ia64__ check to the end)
Comment 2 Agostino Sarubbo gentoo-dev 2012-12-14 19:58:03 UTC

vapier's suggest works here, could you fix?
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-14 20:41:03 UTC
Could you also report to upstream mailing list/bug tracker about this?

If they accept this patch we can include it in the xorg-server-1.13.1 bump.
Comment 4 SpanKY gentoo-dev 2012-12-16 22:16:48 UTC
(In reply to comment #2)

it would be nice to have someone verify the drivers work :)
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-20 22:33:28 UTC
Do you have an update on the upstream status?
Comment 6 Agostino Sarubbo gentoo-dev 2012-12-20 22:41:41 UTC
(In reply to comment #5)
> Do you have an update on the upstream status?

the upstream mailing list rejected my mail, so I'm unable to contact them.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-20 22:42:25 UTC
Did you try to send via gmane? This usually works for me.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-12-25 16:58:05 UTC
Patch added to 1.13.1
Comment 9 Ben 2013-01-03 15:33:46 UTC
I initially saw this and posted about it on but I'll add comments here instead now.

Last night I tried xorg-server-1.13.1 and though it will compile now, it will still not run.  

My lspci w.r.t. the Mach64 (Note it's on bus 1:1:0)

01:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Rage XL (rev 27)

Error that I get in Xorg.0.log:
[ 36620.911]    compiled for 1.13.1, module version = 6.9.4
[ 36620.933] (WW) MACH64: Mach64 in slot 1:1:0 could not be detected!
[ 36620.934] (II) UnloadModule: "mach64"
[ 36620.934] (EE) Screen(s) found, but none have a usable configuration.

which is a strange error indeed.

xf86-video-mach64 6.9.0/6.9.1 - will not compile with missing xaa.h with xorg-server-1.13.1.
xf86-video-mach64 6.9.3 will compile but runtime has same error as 6.9.4.

I reverted back to xorg-server-1.11.4-r1 as it appears to be the last one that will build properly on my ia64 machine.  I will need to set up a second disk drive for testing (would like to keep my raid1 as "stable/working" and hope a working config won't go away...

Not sure if this is a side effect of the patch or not...  Althought it compiles now, it doesn't work :(
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-09 21:52:24 UTC
Problem is not fixed
Comment 11 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-09 21:54:45 UTC
Created attachment 335000 [details, diff]

Debian patch from Stephan Schreiber to implement the missing functions
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-01-09 21:55:43 UTC
Created attachment 335002 [details, diff]

Patch that fixes X server hang on startup on ia64.
Comment 13 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-09-11 21:15:23 UTC
Patches applied in
Comment 14 David Heidelberg (okias) 2014-07-31 00:21:43 UTC
patch has to be rebased and tested for =xorg-server-9999
Comment 15 David Heidelberg (okias) 2014-09-16 20:19:30 UTC
patch is broken again, how look upstream bug? I do not see any link to upstream bugtracker.
Comment 16 David Heidelberg (okias) 2014-10-03 12:00:34 UTC
patch xorg-server-1.12-ia64-fix_inx_outx.patch removed, if you need it, please proviede updated version or even better, get patch into upstream.