Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 440548

Summary: media-libs/gst-plugins-ugly-0.10.18: some elog messages should only be shown when upgrading from an old enough package.
Product: Gentoo Linux Reporter: poletti.marco
Component: Current packagesAssignee: GStreamer package maintainers <gstreamer>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 440214    

Description poletti.marco 2012-10-31 11:29:20 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package media-libs/gst-plugins-ugly-0.10.18, the following elog messages are displayed:

 * The Gstreamer plugins setup has changed quite a bit on Gentoo,
 * applications now should provide the basic plugins needed.
 * 
 * The new seperate plugins are all named 'gst-plugins-<plugin>'.
 * To get a listing of currently available plugins execute 'emerge -s gst-plugins-'.
 * In most cases it shouldn't be needed though to emerge extra plugins.

Such messages should only be displayed when the package is upgraded from an old enough package (and possibly for new installs).
These situations can be checked in the ebuild as follows:

if has_version '<media-libs/gst-plugins-ugly-1.0'; then

Or, if the message should also be displayed for new installs:

if !has_version 'media-libs/gst-plugins-ugly' || has_version '<media-libs/gst-plugins-ugly-1.0'; then

Remember to replace 1.0 with the right version number.

See the tracker bug 440214 for more details.
Comment 1 Gilles Dartiguelongue gentoo-dev 2012-10-31 12:37:30 UTC
Closing as duplicate of bug #440546 since this is the same issue.

*** This bug has been marked as a duplicate of bug 440546 ***