Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 440546 - media-libs/gst-plugins-good-0.10.30: some elog messages should only be shown when upgrading from an old enough package.
Summary: media-libs/gst-plugins-good-0.10.30: some elog messages should only be shown ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords: InVCS
: 440548 (view as bug list)
Depends on:
Blocks: first-time-messages
  Show dependency tree
 
Reported: 2012-10-31 11:29 UTC by poletti.marco
Modified: 2012-12-02 19:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description poletti.marco 2012-10-31 11:29:18 UTC
Disclaimer: this bug has been filed in a semi-automated manner.

When emerging the package media-libs/gst-plugins-good-0.10.30, the following elog messages are displayed:

 * The Gstreamer plugins setup has changed quite a bit on Gentoo,
 * applications now should provide the basic plugins needed.
 * The new seperate plugins are all named 'gst-plugins-<plugin>'.
 * To get a listing of currently available plugins execute 'emerge -s gst-plugins-'.
 * In most cases it shouldn't be needed though to emerge extra plugins.

Such messages should only be displayed when the package is upgraded from an old enough package (and possibly for new installs).
These situations can be checked in the ebuild as follows:

if has_version '<media-libs/gst-plugins-good-1.0'; then

Or, if the message should also be displayed for new installs:

if !has_version 'media-libs/gst-plugins-good' || has_version '<media-libs/gst-plugins-good-1.0'; then

Remember to replace 1.0 with the right version number.

See the tracker bug 440214 for more details.
Comment 1 Gilles Dartiguelongue gentoo-dev 2012-10-31 12:36:24 UTC
This whole message comes from gstreamer eclasses and has been irrelevant for a while. It should be removed and be transformed to a news item next time it happens.
Comment 2 Gilles Dartiguelongue gentoo-dev 2012-10-31 12:37:30 UTC
*** Bug 440548 has been marked as a duplicate of this bug. ***
Comment 3 Gilles Dartiguelongue gentoo-dev 2012-12-02 19:15:37 UTC
Those messages were actually not in the eclasses but since they relate to 
really old releases, I just dropped them.