Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 434908 (PR54694)

Summary: sys-devel/gcc-4.6.3: ICE in .../work/qemu-kvm-1.1.1/target-i386/op_helper.c:3650:1: internal compiler error: in dwarf2out_frame_debug_expr, at dwarf2out.c:2387
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: [OLD] Core systemAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED FIXED    
Severity: normal CC: aidecoe, brytonlee01, luke-jr+gentoobugs, pageexec, qemu
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://gcc.gnu.org/PR54694
See Also: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=54694
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build log
/tmp/op_helper.o

Description Toralf Förster gentoo-dev 2012-09-13 15:14:16 UTC
/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/target-i386/op_helper.c:3650:1: internal compiler error: in dwarf2out_frame_debug_expr, at dwarf2out.c:2387
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.gentoo.org/> for instructions.
{standard input}: Assembler messages:
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
make[1]: *** [op_helper.o] Error 1
make[1]: *** Waiting for unfinished jobs....
  CC    i386-linux-user/exec.o



app-emulation/qemu-kvm-1.1.1-r1 built fine (with gcc-4.5.3 IIRC)

Reproducible: Always




tfoerste@n22 ~ $ emerge --info app-emulation/qemu-kvm
Portage 2.1.11.9 (default/linux/x86/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r2, 3.5.3 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.5.3-i686-Intel-R-_Core-TM-_i5-2540M_CPU_@_2.60GHz-with-gentoo-2.1
Timestamp of tree: Wed, 12 Sep 2012 20:15:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo toralf
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going=y --nospinner --tree --deep --quiet-build"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.mneisen.org/ http://www.gtlib.gatech.edu/pub/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bittorrent branding bzip2 cairo cdda cdr classic cli consolekit corefonts cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild ffmpeg firefox flac fontconfig fortran g3dvl gdbm gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu kvm lcms ldap libnotify lirc logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nsplugin ntfs ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qemu qt3support qt4 rdesktop readline sdl session sna spell sse sse2 sse4_1 ssl ssse3 startup-notification svg tcpd thinkpad threads tiff tk transparent-proxy truetype udev udisks unicode upower usb v4l vaapi vim-syntax vlc vnc vorbis wxwidgets x264 x86 xa xcb xcomposite xinerama xml xpm xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-emulation/qemu-kvm-1.1.1-r1 was built with the following:
USE="aio alsa caps (consolekit) curl ncurses opengl (policykit) sdl test vhost-net -bluetooth -brltty -debug -doc -fdt -pulseaudio -python (-rbd) -sasl -smartcard (-spice) -static -tci -tls -usbredir -vde -virtfs -xattr -xen -xfs" QEMU_SOFTMMU_TARGETS="i386 x86_64 (-alpha) (-arm) -cris (-m68k) -microblaze -microblazeel (-mips) -mips64 -mips64el -mipsel (-ppc) (-ppc64) -ppcemb -s390x -sh4 -sh4eb (-sparc) -sparc64 -xtensa -xtensaeb" QEMU_USER_TARGETS="i386 x86_64 (-alpha) (-arm) -armeb -cris (-m68k) -microblaze -microblazeel (-mips) -mipsel (-ppc) (-ppc64) -ppc64abi32 -s390x -sh4 -sh4eb (-sparc) -sparc32plus -sparc64 -unicore32"
Comment 1 Toralf Förster gentoo-dev 2012-09-13 15:14:35 UTC
Created attachment 323670 [details]
build log
Comment 2 SpanKY gentoo-dev 2012-09-16 05:17:51 UTC
please go to the build dir, find the failing gcc command, and then replace the compile flag (-c) with -E and then attach the output (.o) from that here.
Comment 3 Toralf Förster gentoo-dev 2012-09-16 09:07:57 UTC
Created attachment 323978 [details]
/tmp/op_helper.o
Comment 4 SpanKY gentoo-dev 2012-09-16 20:30:45 UTC
(In reply to comment #3)

what was the command you ran exactly ?  when i try to build, i get bp reg errors.
Comment 5 Toralf Förster gentoo-dev 2012-09-17 17:02:01 UTC
I made "make -n" and then copy+paste+replaced it :

i686-pc-linux-gnu-gcc -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/slirp -I. -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1 -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/fpu -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/linux-headers -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/tcg -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/tcg/i386  -fPIE -DPIE -m32 -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Wstrict-prototypes -Wredundant-decls -Wall -Wundef -Wwrite-strings -Wmissing-prototypes -fno-strict-aliasing  -fstack-protector-all -Wendif-labels -Wmissing-include-dirs -Wempty-body -Wnested-externs -Wformat-security -Wformat-y2k -Winit-self -Wignored-qualifiers -Wold-style-declaration -Wold-style-definition -Wtype-limits -I/usr/include/libpng15   -DHAS_AUDIO -DHAS_AUDIO_CHOICE  -DTARGET_PHYS_ADDR_BITS=64 -I../linux-headers -I.. -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/target-i386 -DNEED_CPU_H -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/include    -I/usr/include/libpng15   -fomit-frame-pointer -MMD -MP -MT op_helper.o -MF ./op_helper.d -O2 -O2 -march=native -pipe -E -o op_helper.o /var/tmp/portage/app-emulation/qemu-kvm-1.1.1-r3/work/qemu-kvm-1.1.1/target-i386/op_helper.c
Comment 6 SpanKY gentoo-dev 2012-09-24 01:47:23 UTC
can't reproduce it over here.  gcc 4.6.3 compiles it just fine.
Comment 7 Toralf Förster gentoo-dev 2012-09-26 18:09:14 UTC
(In reply to comment #6)
> can't reproduce it over here.  gcc 4.6.3 compiles it just fine.

upstream accepted it : http://gcc.gnu.org/bugzilla/show_bug.cgi?id=54694#c5
Comment 8 SpanKY gentoo-dev 2012-09-27 00:38:02 UTC
(In reply to comment #7)

yes, it's because your -march=native expands differently from mine
Comment 9 Ryan Hill (RETIRED) gentoo-dev 2012-09-29 04:50:51 UTC
*** Bug 410985 has been marked as a duplicate of this bug. ***
Comment 10 Doug Goldstein gentoo-dev 2012-10-20 16:59:39 UTC
*** Bug 365147 has been marked as a duplicate of this bug. ***
Comment 11 Luke-Jr 2013-01-03 19:01:38 UTC
Workaround: Append -mno-avx to CFLAGS.
Comment 12 Toralf Förster gentoo-dev 2013-01-03 19:36:59 UTC
(In reply to comment #11)
> Workaround: Append -mno-avx to CFLAGS.

works - thx for this hint
Comment 13 Toralf Förster gentoo-dev 2013-01-04 21:00:13 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Workaround: Append -mno-avx to CFLAGS.
> 
> works - thx for this hint

FWIW - 1.2.1 compiles fine without changing the CFLAGS
Comment 14 Toralf Förster gentoo-dev 2014-01-16 16:51:26 UTC
gcc devs fixed the issue :

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=54694
Comment 15 SpanKY gentoo-dev 2014-05-31 16:09:54 UTC
seems like it'd be easy for us to backport to gcc-4.6

https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=206667
Comment 16 Toralf Förster gentoo-dev 2016-01-31 18:27:02 UTC
4 years old ...
Comment 17 Andreas K. Hüttel gentoo-dev 2017-08-13 06:18:10 UTC
Fixed in all since 4.9.0