Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410985 - app-emulation/qemu-kvm-0.15.1-r1 - In function ‘helper_flds_FT0’: /var/tmp/portage/app-emulation/qemu-kvm-0.15.1-r1/work/qemu-kvm-0.15.1/target-i386/op_helper.c:3531:1: internal compiler error: in dwarf2out_frame_debug_expr, at dwarf2out.c:2261
Summary: app-emulation/qemu-kvm-0.15.1-r1 - In function ‘helper_flds_FT0’: /var/tmp/po...
Status: RESOLVED DUPLICATE of bug 434908
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-06 03:33 UTC by Bryton Lee
Modified: 2012-09-29 04:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build info (qemu-kvm-0.15.1-r1.ebuild,9.35 KB, text/plain)
2012-04-06 03:33 UTC, Bryton Lee
Details
build log (build.log,15.46 KB, text/plain)
2012-04-07 11:52 UTC, Bryton Lee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryton Lee 2012-04-06 03:33:54 UTC
Created attachment 307953 [details]
build info

I tried to install qemu-kvm-0.15.1-r1 on my laptop(lenovo x220), I have configured my kernel configure appropriate, and I have installed qemu successfully, but after unmeger qemu, then emerge qemu-kvm, It failed. I have seached in google and bugzilla, no result, so I post here(it's my first time to file a bug in english, maybe it's not descripted well soryy!). 

================================part 1======================================
Portage 2.1.10.49 (default/linux/x86/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.2.6-gentoo i686)
=================================================================
System uname: Linux-3.2.6-gentoo-i686-Intel-R-_Core-TM-_i5-2410M_CPU_@_2.30GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 06 Apr 2012 01:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirrors.stuhome.net/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cli consolekit cracklib crypt cscope cups cxx dbus directfb dri dts dvd dvdr emboss encode exif fam fbcon fbcondecor firefox flac fontconfig fortran gdbm gdu gif gnome gpm gstreamer gtk iconv ipv6 irc jabber jpeg kvm lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg msn mudflap ncurses networkmanager nls nptl nptlonly objc ogg opengl openmp pam pango pcre pdf png policykit ppds pppd python qt3support readline samba sdl session sip spell sqlite sse sse2 sse3 sse4 ssl ssse3 startup-notification svg sysfs tcpd tiff truetype udev unicode usb v4l vaapi vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

================================part 2======================================
gentoo_thinkpad linux # emerge -av qemu-kvm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-emulation/qemu-kvm-0.15.1-r1  USE="aio alsa bluetooth jpeg ncurses png sdl ssl vhost-net -brltty -curl -debug -fdt -hardened -nss -pulseaudio -qemu-ifup (-rbd) -sasl (-spice) -threads -vde -xattr -xen" QEMU_SOFTMMU_TARGETS="i386 -arm -cris -m68k -microblaze -mips -mips64 -mips64el -mipsel -ppc -ppc64 -ppcemb -sh4 -sh4eb -sparc -sparc64 -x86_64" QEMU_USER_TARGETS="i386 -alpha -arm -armeb -cris -m68k -microblaze -mips -mipsel -ppc -ppc64 -ppc64abi32 -sh4 -sh4eb -sparc -sparc32plus -sparc64 -x86_64" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

=================================part 3=====================================

  CC    i386-softmmu/ivshmem.o
  CC    i386-softmmu/exec.o
/var/tmp/portage/app-emulation/qemu-kvm-0.15.1-r1/work/qemu-kvm-0.15.1/target-i386/op_helper.c: In function ‘helper_flds_FT0’:
/var/tmp/portage/app-emulation/qemu-kvm-0.15.1-r1/work/qemu-kvm-0.15.1/target-i386/op_helper.c:3531:1: internal compiler error: in dwarf2out_frame_debug_expr, at dwarf2out.c:2261

/var/tmp/portage/app-emulation/qemu-kvm-0.15.1-r1/work/qemu-kvm-0.15.1/target-i386/op_helper.c: In function ‘helper_flds_FT0’:
/var/tmp/portage/app-emulation/qemu-kvm-0.15.1-r1/work/qemu-kvm-0.15.1/target-i386/op_helper.c:3531:1: internal compiler error: in dwarf2out_frame_debug_expr, at dwarf2out.c:2261
Please submit a full bug report,
with preprocessed source if appropriate.
Comment 1 Jeroen Roovers gentoo-dev 2012-04-06 14:49:41 UTC
Comment on attachment 307953 [details]
build info

That's the ebuild that failed??
Comment 2 Jeroen Roovers gentoo-dev 2012-04-06 14:53:11 UTC
Please attach the entire build log to this bug report.
Comment 3 Bryton Lee 2012-04-07 11:52:46 UTC
Created attachment 308085 [details]
build log

sorry! I attatched a wrong file, now the attatchment is correct one.
Comment 4 Doug Goldstein gentoo-dev 2012-07-29 21:13:05 UTC
Can you retest with a newer version? I believe this has been fixed with an update to the toolchain.
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2012-09-29 04:50:51 UTC

*** This bug has been marked as a duplicate of bug 434908 ***