Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 399259

Summary: sys-devel/icecream-0.9.7: icecream-create-env failed with: "/usr/lib/icecc/icecc-create-env: No such file or directory"
Product: Gentoo Linux Reporter: Vu Tran Kien <>
Component: Current packagesAssignee: Gentoo Cluster Team <cluster>
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: files/0.9.7-icecream-create-env.patch
changes needed in icecream-0.9.7.ebuild

Description Vu Tran Kien 2012-01-18 07:12:59 UTC
after emerge --sync today (2012/01/18) and emerge sys-devel/icecream, I issued icecream-create-env and it failed with:
/usr/lib/icecc/icecc-create-env: No such file or directory.

That's odd because on other computer that operation completed successfully.
I think it may relate to bug #397715 because prior to that /usr/lib/icecc/icecc-create-env existed but after that bug fixed it's gone.

'equery files icecream' shows that it lies in /usr/share/icecc/icecc-create-env
Comment 1 Karsten Merkle 2012-01-22 15:46:48 UTC
Created attachment 299543 [details, diff]

patch needed to resolve this bug
Comment 2 Karsten Merkle 2012-01-22 15:50:03 UTC
Created attachment 299545 [details, diff]
changes needed in icecream-0.9.7.ebuild

this together with previous attachement should resolve this bug
Comment 3 Thomas Elste 2012-03-06 22:09:51 UTC
I had the same issues with icecream, too. Trying the fixes posted here I noticed that changing the path to icecc-create-env in the icecream-create-env script still isn't enough to get icecream working again. The reason for this is that the path to icecc-create-env is hard coded by some autoconf variable in the icecream client, too.

Instead of changing I replaced the patch from bug #397715 which introduced the path change through the one posted here which addresses the same problem:

With this patch the env script stays at its former place and the environment setup runs again.

Anyhow icecream still doesn't work for me. There's another problem with missing libraries in the icecream environment: bug #407173.
Comment 4 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-08-23 10:44:36 UTC
+  23 Aug 2012; Kacper Kowalik <>
+  +files/0.9.7-automake.patch, +icecream-0.9.7-r1.ebuild,
+  -files/0.9.7-automake-1.11.2.patch, -icecream-0.9.6-r1.ebuild,
+  -icecream-0.9.7.ebuild:
+  Backport patch fixing build issues with recent automake, drop my patch that
+  caused bug #399259 by Vu Tran Kien <>

Please, reopen if issue persists
Comment 5 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-08-23 10:58:11 UTC
+  23 Aug 2012; Kacper Kowalik <> files/icecream-create-env:
+  Update path to icecc-create-env wrt #399259, missed in previous commit