Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 380013

Summary: x11-libs/cairo-1.10.x fails with Qt 4.8
Product: Gentoo Linux Reporter: Georg Rudoy <0xd34df00d>
Component: [OLD] LibraryAssignee: Doug Goldstein (RETIRED) <cardoe>
Status: RESOLVED FIXED    
Severity: major CC: asturm, franz.trischberger, galtgendo, kevin.bowling, matej, niels_ole, qt, spatz, x11
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.freedesktop.org/show_bug.cgi?id=29092
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 394903    
Attachments: Fix pango with Qt 4.8.

Description Georg Rudoy 2011-08-20 22:55:11 UTC
Created attachment 284073 [details]
Fix pango with Qt 4.8.

Compiling pango with Qt 4.8 (beta1) makes pango unusable, since Qt's developers removed some of the internal API in the upcoming Qt 4.8 release that pango relies on.

This unusability manifests itself in errors like:

undefined reference to `qt_draw_glyphs(QPainter*, unsigned int const*, QPointF const*, int)'

with apps/libraries using pango (for example, I came across this while compiling cairo).

Here's the issue at freedesktop's bugtracker: https://bugs.freedesktop.org/show_bug.cgi?id=29092 , and comments 10-11 seem to be the most relevant ones.

I'm attaching the patch for Qt 4.8 compatibility from that issue here. It seems to fix the issue my installation, but it'd better be tested with older Qt versions like 4.7 and 4.6.
Comment 1 Georg Rudoy 2011-08-20 22:56:54 UTC
Oh, the patch is actually for cairo, I messed things up in the original report: every occurance of cairo should be replaced with pango, and vice versa.

Sorry.
Comment 2 Andreas Sturmlechner gentoo-dev 2011-12-18 19:28:04 UTC
Thanks for posting this, I confirm error (qt-*-4.8.9999 from qting-edge) + solution. In my case I noticed by several failing packages (oxygen, audacity and gparted), both built successfully after fixed cairo rebuild.
Comment 3 Andreas Sturmlechner gentoo-dev 2011-12-19 00:45:13 UTC
Correction. The patch makes the cairo qt backend unusable, the aforementionend applications that were rebuilt let X segfault.

audacity: starting it trows me back to kdm immediately (no error in dmesg but in X.log.

firefox (using oxygen-gtk): after a few seconds, kwin crashes, dmesg has the following output:

[   57.640146] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[   57.640156] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[   57.647377] [drm:i915_wait_request] *ERROR* i915_wait_request returns -11 (awaiting 4730 at 4711, next 4737)
[   58.149081] [drm:i915_reset] *ERROR* Failed to reset chip.
Comment 4 Andreas Sturmlechner gentoo-dev 2011-12-19 00:49:43 UTC
gparted: same as audacity
Comment 5 Andreas Sturmlechner gentoo-dev 2011-12-24 23:09:33 UTC
patched cairo ebuild in x11-overlay works.
Comment 6 Davide Pesavento gentoo-dev 2012-01-12 16:17:43 UTC
*** Bug 395507 has been marked as a duplicate of this bug. ***
Comment 7 Matěj Laitl 2012-01-30 11:49:34 UTC
This is apparently fixed in x11-libs/cairo-1.10.2-r2
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-01-30 13:29:24 UTC
+*cairo-1.10.2-r2 (29 Jan 2012)
+
+  29 Jan 2012; Alex Alexander <wired@gentoo.org> +cairo-1.10.2-r2.ebuild,
+  +files/cairo-1.10.2-qt-surface.patch:
+  revbump with patch for Qt-4.8. bug #380013