Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 395507 - x11-libs/cairo needs to be patched for qt-4.8.0
Summary: x11-libs/cairo needs to be patched for qt-4.8.0
Status: RESOLVED DUPLICATE of bug 380013
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein (RETIRED)
URL: https://bugs.freedesktop.org/attachme...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-21 10:36 UTC by Franz Trischberger
Modified: 2012-01-12 16:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libdrm failing (1325167842-install-x11-libs_libdrm-2.4.29:0::gentoo.out,25.08 KB, text/plain)
2011-12-29 14:11 UTC, Franz Trischberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Trischberger 2011-12-21 10:36:44 UTC
The recent update of libdrm-2.4.29 failed with the following error:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.2/../../../../lib64/libcairo.so: undefined reference to `qt_draw_glyphs(QPainter*, unsigned int const*, QPointF const*, int)'

Searching for a solution, I found this bugreport:
https://bugs.freedesktop.org/show_bug.cgi?id=29092

The proposed patch:
https://bugs.freedesktop.org/attachment.cgi?id=50411
applied to cairo-1.10.2, recompiled cairo, now libdrm linked fine.
As soon as qt-4.8.0 hits the tree, this patch should be applied to cairo.

Reproducible: Always
Comment 1 Andreas Sturmlechner gentoo-dev 2011-12-24 23:13:07 UTC
I am confused, since when does libdrm depend on cairo?

There is a cairo ebuild inside x11-overlay including the patch which works for me.
Comment 2 Franz Trischberger 2011-12-29 14:11:59 UTC
Created attachment 297299 [details]
libdrm failing

It is not libdrm itself, but "modetest" that seems to link against libcairo.
(Log just to not leave this problem "unresolved")
Comment 3 Davide Pesavento gentoo-dev 2012-01-12 16:17:43 UTC

*** This bug has been marked as a duplicate of bug 380013 ***