Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 342785

Summary: app-arch/tar-1.24 fails to extract specified directories from kdebase-4.5.2.tar.bz2 (for example, kde-base/libkonq-4.5.2)
Product: Gentoo Linux Reporter: Samuli Suominen <ssuominen>
Component: Current packagesAssignee: Gentoo's Team for Core System packages <base-system>
Status: VERIFIED FIXED    
Severity: normal CC: bugs, itrombley, kde, mobiusstripper, pappy_mcfae, SDNick484
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://git.savannah.gnu.org/cgit/tar.git/commit/?id=28e91b48f680a6fab90ee39145123647345f385f
Whiteboard:
Package list:
Runtime testing required: ---

Description Samuli Suominen gentoo-dev 2010-10-26 16:32:28 UTC
tar-1.24 fails to extract libkonq-4.5.2 properly, even with the upstream patch from:

http://bugs.gentoo.org/show_bug.cgi?id=342735#c5

To make it clear: Solving bug 342735 won't fix this issue.

>>> Emerging (2 of 2) kde-base/libkonq-4.5.2
 * kdebase-4.5.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                          [ ok ]
 * Package:    kde-base/libkonq-4.5.2
 * Repository: gentoo
 * Maintainer: kde
 * USE:  amd64 elibc_glibc kernel_linux multilib userland_GNU
You should enable -g (or higher) for debugging!
>>> Unpacking source...
 * Unpacking parts of kdebase-4.5.2.tar.bz2 to /var/tmp/portage/kde-base/libkonq-4.5.2/work ...
mv: cannot stat `kdebase-4.5.2/': No such file or directory
 * ERROR: kde-base/libkonq-4.5.2 failed:
 *   Died while moving "kdebase-4.5.2/" to "libkonq-4.5.2"
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 4223:  Called kde4-meta_src_unpack
 *   environment, line 3397:  Called kde4-meta_src_extract
 *   environment, line 3343:  Called die
 * The specific snippet of code:
 *           mv ${topdir} ${P} || die "Died while moving \"${topdir}\" to \"${P}\"";
 * 
 * If you need support, post the output of 'emerge --info =kde-base/libkonq-4.5.2',
 * the complete build log and the output of 'emerge -pqv =kde-base/libkonq-4.5.2'.
 * The complete build log is located at '/home/ssuominen/logs/kde-base:libkonq-4.5.2:20101026-162956.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/libkonq-4.5.2/temp/environment'.
 * S: '/var/tmp/portage/kde-base/libkonq-4.5.2/work/libkonq-4.5.2'
Comment 1 Samuli Suominen gentoo-dev 2010-10-26 16:35:19 UTC
Nothing extracted here:

# cd /var/tmp/portage/kde-base/libkonq-4.5.2
# find ./
./
./homedir
./.ipc_out
./.ipc_in
./.die_hooks
./.logid
./work
./.setuped
./distdir
./distdir/kdebase-4.5.2.tar.bz2
./temp
./temp/environment
./temp/eclass-debug.log
./temp/logging
Comment 2 Samuli Suominen gentoo-dev 2010-10-26 16:49:19 UTC
kde4-meta.eclass calls tar's with directories it should extract, to reproduce out of emerge it like:

tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2 --bzip2 --transform="s|apps/||" apps/konsole

or

# tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2 --bzip2 --transform="s|apps/||" konsole
# tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2 --bzip2 --transform="s|apps/||" apps/konsole
# tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2 apps/konsole
# tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2 konsole

it always claims:

tar: apps/konsole: Not found in archive
tar: Exiting with failure status due to previous errors

but the directory is there in the archive
Comment 3 SpanKY gentoo-dev 2010-10-26 17:14:35 UTC
should e-mail bug-tar@gnu.org before they put out a tar-1.25 with the fix for the previous -C issue ...
Comment 4 Samuli Suominen gentoo-dev 2010-10-26 17:52:06 UTC
(In reply to comment #3)
> should e-mail bug-tar@gnu.org before they put out a tar-1.25 with the fix for
> the previous -C issue ...
> 

Should be done, just registered to the ML and mailed it there. The example in Comment #2 suck anyway, so I'll post working example here (this was sent to ML):



tar-1.24 fails to extract specified directories from
kdebase-4.5.2.tar.bz2 [1] as reported downstream [2].

tar-1.23 success:

unique tmp # tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2
--transform="s|apps/||" kdebase-4.5.2/apps/konsole
unique tmp #

tar-1.24 failure with (or without, doesn't make difference):
http://git.savannah.gnu.org/cgit/tar.git/patch/?id=acb77ac5bd4bf9248070c9c512525eee8258aebd

unique tmp # tar -xpf /usr/portage/distfiles/kdebase-4.5.2.tar.bz2
--transform="s|apps/||" kdebase-4.5.2/apps/konsole
tar: kdebase-4.5.2/apps/konsole: Not found in archive
tar: Exiting with failure status due to previous errors

[1] http://trumpetti.atm.tut.fi/gentoo/distfiles/kdebase-4.5.2.tar.bz2
[2] http://bugs.gentoo.org/show_bug.cgi?id=342785
Comment 5 Samuli Suominen gentoo-dev 2010-10-26 19:53:45 UTC
Fixed in git by this commit:

http://git.savannah.gnu.org/cgit/tar.git/commit/?id=28e91b48f680a6fab90ee39145123647345f385f
Comment 6 Samuli Suominen gentoo-dev 2010-10-27 12:28:40 UTC
(In reply to comment #5)
> Fixed in git by this commit:
> 
> http://git.savannah.gnu.org/cgit/tar.git/commit/?id=28e91b48f680a6fab90ee39145123647345f385f
> 

and this one is required too:

http://git.savannah.gnu.org/cgit/tar.git/commit/?id=5af29cb944c84e2d539ce9df527d63c29f6012b9

it complements the prev. commit
Comment 7 SpanKY gentoo-dev 2010-10-27 17:57:34 UTC
if you want to do a -r1 with those two patches, feel free.  i wouldnt worry about the test failures for now as there'll be a 1.25 out with those fixed.  this wold at least get us to test 1.24 a little more ...
Comment 8 Samuli Suominen gentoo-dev 2010-10-27 18:19:58 UTC
(In reply to comment #7)
> if you want to do a -r1 with those two patches, feel free.  i wouldnt worry
> about the test failures for now as there'll be a 1.25 out with those fixed. 
> this wold at least get us to test 1.24 a little more ...
> 

I left the testsuite bits out from the patches on purpose, they touch Makefile.am which triggers maintainer-mode.

+*tar-1.24-r1 (27 Oct 2010)
+
+  27 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> +tar-1.24-r1.ebuild,
+  +files/tar-1.24-mkdirat.patch, +files/tar-1.24-transform.patch,
+  +files/tar-1.24-transform-2.patch:
+  Fix -C switch wrt #342735 by "ferret". Fix --transform switch wrt #342785.
Comment 9 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-10-28 18:36:36 UTC
*** Bug 343027 has been marked as a duplicate of this bug. ***
Comment 10 Samuli Suominen gentoo-dev 2010-11-11 22:05:59 UTC
*** Bug 343193 has been marked as a duplicate of this bug. ***
Comment 11 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2010-11-14 00:51:36 UTC
*** Bug 343921 has been marked as a duplicate of this bug. ***
Comment 12 Vasilis Lourdas 2011-03-04 22:55:36 UTC
I get the same error with libkonq-4.6.1:

>>> Emerging (1 of 190) kde-base/libkonq-4.6.1
 * kdebase-4.6.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                             [ ok ]
 * Package:    kde-base/libkonq-4.6.1
 * Repository: gentoo
 * Maintainer: kde@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
 * Unpacking parts of kdebase-4.6.1.tar.bz2 to /var/tmp/portage/kde-base/libkonq-4.6.1/work ...
tar extract command failed at least partially - continuing anyway
mv: cannot stat `kdebase-4.6.1/': No such file or directory
 * ERROR: kde-base/libkonq-4.6.1 failed (unpack phase):
 *   Died while moving "kdebase-4.6.1/" to "libkonq-4.6.1"
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 4339:  Called kde4-meta_src_unpack
 *   environment, line 3512:  Called kde4-meta_src_extract
 *   environment, line 3458:  Called die
 * The specific snippet of code:
 *           mv ${topdir} ${P} || die "Died while moving \"${topdir}\" to \"${P}\"";
 * 
 * If you need support, post the output of 'emerge --info =kde-base/libkonq-4.6.1',
 * the complete build log and the output of 'emerge -pqv =kde-base/libkonq-4.6.1'.
 * The complete build log is located at '/var/tmp/portage/kde-base/libkonq-4.6.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/libkonq-4.6.1/temp/environment'.
 * S: '/var/tmp/portage/kde-base/libkonq-4.6.1/work/libkonq-4.6.1'
Comment 13 Andreas K. Hüttel gentoo-dev 2011-03-04 23:20:01 UTC
(In reply to comment #12)
> I get the same error with libkonq-4.6.1:
> 

Different problem, but now also fixed.