Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 343193 - kde-base/libkonq-4.5.2 failed to unpacked
Summary: kde-base/libkonq-4.5.2 failed to unpacked
Status: RESOLVED DUPLICATE of bug 342785
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 23:31 UTC by Mathieu Z
Modified: 2010-11-11 22:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Z 2010-10-28 23:31:56 UTC
This seems to be the same problem with an older closed bug #261801.

 * Unpacking parts of kdebase-4.5.2.tar.bz2 to /var/tmp/portage/kde-base/libkonq-4.5.2/work ...
mv: cannot stat `kdebase-4.5.2/': No such file or directory
 * ERROR: kde-base/libkonq-4.5.2 failed:
 *   Died while moving "kdebase-4.5.2/" to "libkonq-4.5.2"
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 4249:  Called kde4-meta_src_unpack
 *   environment, line 3423:  Called kde4-meta_src_extract
 *   environment, line 3369:  Called die


Reproducible: Always

Steps to Reproduce:
1. emerge libkonq
2.
3.




Easily fixed similar to previous bug:

--- libkonq-4.5.2.ebuild	2010-10-28 16:26:41.000000000 -0700
+++ libkonq-4.5.2.ebuild.new	2010-10-28 16:26:22.000000000 -0700
@@ -4,8 +4,8 @@
 
 EAPI="3"
 
-KMNAME="kdebase-app"
-KMMODULE="lib/konq"
+KMNAME="kdebase"
+KMMODULE="apps/lib/konq"
 CPPUNIT_REQUIRED="optional"
 inherit kde4-meta

I am not sure if this is due some change in API with kde4-meta.eclass and expects some new values for KMNAME and KMMODULE?
Comment 1 Mathieu Z 2010-10-28 23:40:53 UTC
seems like there is an update for kde4-meta.eclass?? Other package are failing to emerge for the same reason too:
kde-base/kfmclient-4.5.2
kde-base/kdialog-4.5.2
kde-base/kwrite-4.5.2
kde-base/konsole-4.5.2
kde-base/kfind-4.5.2
...
I am going to go try fix kde4-meta.eclass now.
Comment 2 Mathieu Z 2010-10-29 01:51:35 UTC
in kde4-meta_src_extract(), there is a tar option that remove "apps/" from path of ${extractlist} and as a result the files are not extracted:


--- kde4-meta.eclass.old	2010-10-28 17:11:10.000000000 -0700
+++ kde4-meta.eclass.new	2010-10-28 18:47:35.000000000 -0700
@@ -218,7 +218,7 @@
 				tarball="kdebase-${PV}.tar.${postfix}"
 				# Go one level deeper for kdebase-apps in tarballs
 				moduleprefix=apps/
-				KMTARPARAMS+=" --transform=s|apps/||"
+#				KMTARPARAMS+=" --transform=s|apps/||"
 				;;
 			*)
 				# Create tarball name from module name (this is the default)

Not certain if this is the proper fix.
Comment 3 Matthew Dombroski 2010-11-11 10:24:27 UTC
Reverting kde4-meta.eclass to version 1.42 works for now.
Comment 4 Samuli Suominen gentoo-dev 2010-11-11 22:05:59 UTC

*** This bug has been marked as a duplicate of bug 342785 ***