Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 343027 - Kdialog-4.5.2 Fails to Unpack
Summary: Kdialog-4.5.2 Fails to Unpack
Status: RESOLVED DUPLICATE of bug 342785
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-28 06:33 UTC by Nick Andrade
Modified: 2010-10-28 18:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Andrade 2010-10-28 06:33:55 UTC
* Unpacking parts of kdebase-4.5.2.tar.bz2 to /var/tmp/portage/kde-base/kdialog-4.5.2/work ...
mv: cannot stat `kdebase-4.5.2/': No such file or directory
 * ERROR: kde-base/kdialog-4.5.2 failed:
 *   Died while moving "kdebase-4.5.2/" to "kdialog-4.5.2"


Reproducible: Always

Steps to Reproduce:
1. emerge =kdialog-4.5.2

Actual Results:  
Kdialog fails to unpack which causes the build to fail.

Expected Results:  
Kdialog should build.

>>> Emerging (1 of 1) kde-base/kdialog-4.5.2
 * kdebase-4.5.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                  [ ok ]
 * Package:    kde-base/kdialog-4.5.2
 * Repository: gentoo
 * Maintainer: kde@gentoo.org
 * USE:  amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
 * Unpacking parts of kdebase-4.5.2.tar.bz2 to /var/tmp/portage/kde-base/kdialog-4.5.2/work ...
mv: cannot stat `kdebase-4.5.2/': No such file or directory
 * ERROR: kde-base/kdialog-4.5.2 failed:
 *   Died while moving "kdebase-4.5.2/" to "kdialog-4.5.2"
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 4240:  Called kde4-meta_src_unpack
 *   environment, line 3414:  Called kde4-meta_src_extract
 *   environment, line 3360:  Called die
 * The specific snippet of code:
 *           mv ${topdir} ${P} || die "Died while moving \"${topdir}\" to \"${P}\"";
 * 
 * If you need support, post the output of 'emerge --info =kde-base/kdialog-4.5.2',
 * the complete build log and the output of 'emerge -pqv =kde-base/kdialog-4.5.2'.
 * The complete build log is located at '/var/tmp/portage/kde-base/kdialog-4.5.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdialog-4.5.2/temp/environment'.
 * S: '/var/tmp/portage/kde-base/kdialog-4.5.2/work/kdialog-4.5.2'
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-10-28 11:44:52 UTC
What tar version are you using?
Comment 2 Nick Andrade 2010-10-28 18:29:46 UTC
Jorge, excellent catch.  I was on tar 1.24, and I just checked portage and it wanted me to downgrade to 1.23-r4:
[ebuild     UD] app-arch/tar-1.23-r4 [1.24] USE="nls -static" 0 kB

Switching to tar 1.23-r4 resolved my issue (kdialog now unpacks and builds).  Thanks, again.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-10-28 18:36:36 UTC

*** This bug has been marked as a duplicate of bug 342785 ***