Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 299256

Summary: mail-filter/spamassassin rule FH_DATE_PAST_20XX broken
Product: Gentoo Linux Reporter: Florian Steinel <Florian.Steinel>
Component: [OLD] UnspecifiedAssignee: Gentoo Perl team <perl>
Status: RESOLVED FIXED    
Severity: blocker CC: bugs, dertobi123, gentoo_bugs_peep, halcy0n, jhardin, net-mail+disabled, svrmarty
Priority: High Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://wiki.apache.org/spamassassin/Rules/FH_DATE_PAST_20XX
Whiteboard:
Package list:
Runtime testing required: ---

Description Florian Steinel 2010-01-01 19:18:53 UTC
see
http://wiki.apache.org/spamassassin/Rules/FH_DATE_PAST_20XX

...
Note: the current rule in 3.2 will start matching legitimate dates from 2010-01-01.
...

fix: https://issues.apache.org/SpamAssassin/show_bug.cgi?id=5852
The channels are not uptodate and above fix is not published: https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6269
Comment 1 Mark Loeser (RETIRED) gentoo-dev 2010-01-01 19:37:19 UTC
Pushed the severity up since this is causing false positives at a very high rate.
Comment 2 David Abbott gentoo-dev 2010-01-01 21:17:09 UTC
A new update has been added;
5.2.3.updates.spamassassin.org => 895063

sa-update --checkonly  -D
sa-update -D

If all goes well;
/etc/init.d/spamd restart
Comment 3 Tobias Scherbaum (RETIRED) gentoo-dev 2010-01-01 21:54:54 UTC
(In reply to comment #2)
> A new update has been added;
> 5.2.3.updates.spamassassin.org => 895063
> 
> sa-update --checkonly  -D
> sa-update -D
> 
> If all goes well;
> /etc/init.d/spamd restart
> 

Guess there's nothing we can do on this now - or would you prefer having a quickly bump to stable spamassassin with a fix for that? Might be reasonable as probably not that many people out there are using sa-update.
Comment 4 Mark Loeser (RETIRED) gentoo-dev 2010-01-01 22:00:27 UTC
(In reply to comment #3)
> Guess there's nothing we can do on this now - or would you prefer having a
> quickly bump to stable spamassassin with a fix for that? Might be reasonable as
> probably not that many people out there are using sa-update.
> 

Make a quick patch against our current stable which patches the rule that is installed, and have that made stable as soon as possible.  We want it to be usable out of the box :)
Comment 5 Tobias Scherbaum (RETIRED) gentoo-dev 2010-01-01 22:26:37 UTC
(In reply to comment #4)
> Make a quick patch against our current stable which patches the rule that is
> installed, and have that made stable as soon as possible.  We want it to be
> usable out of the box :)
> 

spamassassin-3.2.1-r2 in CVS. Already stable for ppc && hppa. Adding arches, make this a quick one please :)
Comment 6 Tobias Klausmann gentoo-dev 2010-01-02 00:00:00 UTC
Stable on alpha.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-02 03:31:17 UTC
*** Bug 299300 has been marked as a duplicate of this bug. ***
Comment 8 Torsten Veller (RETIRED) gentoo-dev 2010-01-02 07:48:38 UTC
Stable on x86 and amd64
Comment 9 Philippe Chaintreuil 2010-01-02 13:19:27 UTC
Thanks for the quick turn around on this one guys!
Comment 10 Brent Baude (RETIRED) gentoo-dev 2010-01-02 14:39:56 UTC
ppc64 done
Comment 11 Raúl Porcel (RETIRED) gentoo-dev 2010-01-02 15:19:17 UTC
ia64/sparc stable, closing
Comment 12 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-06 12:08:23 UTC
*** Bug 299874 has been marked as a duplicate of this bug. ***
Comment 13 John Hardin 2010-01-15 16:15:12 UTC
3.2.5 is nearly two years old and 3.2.1 has serious bugs, and 3.3.0 is days away from release.

Having the stable release of an important and perishable tool like SpamAssassin be a version that is more than two years old is a big problem for someone who wants to build a mailserver using Gentoo. 3.2.1 will perform poorly these days.

Tobias, what is keeping 3.2.5 from being marked stable?