Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 299874 - mail-filter/spamassassin-3.2.1-r1 : bad handling of email date after 31/12/2009
Summary: mail-filter/spamassassin-3.2.1-r1 : bad handling of email date after 31/12/2009
Status: RESOLVED DUPLICATE of bug 299256
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL: https://issues.apache.org/SpamAssassi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-06 11:51 UTC by Aurélien Requiem
Modified: 2010-01-06 12:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aurélien Requiem 2010-01-06 11:51:55 UTC
Hi,

there's a "buzzing" bug in spamassassin that add over 3 points for email with date in 2010 and after. This obviously scores clean mail and could lead to false positive.

The problem is already know and fixed in the upstream.

This bug to backport the fix in gentoo as long as no new version is available.


Reproducible: Always

Steps to Reproduce:
1. send a mail with a date equal of above 2010
2. the mail will be scored with +3.44 point and match the  rule FH_DATE_PAST_20XX

Actual Results:  
depending on other scoring your mail could be considered as spam when it's not.


Expected Results:  
the mail should match the FH_DATE_PAST_20XX rule 

Please, have look there as the problem is clearly known
https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6269

Thank you.
Comment 1 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-06 12:08:23 UTC

*** This bug has been marked as a duplicate of bug 299256 ***