Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 262038

Summary: Portage does not check identical packages in all overlays
Product: Portage Development Reporter: Marco Leogrande <dark.knight.ita>
Component: CoreAssignee: Portage team <dev-portage>
Severity: normal CC: esigra, gentoo, jlec, jsled, nikoli, pesa, pva, sping
Priority: High Keywords: InVCS
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 240187, 333599, 358927    

Description Marco Leogrande 2009-03-10 20:44:48 UTC
dev-java/gjdoc-0.7.9 was marked stable on x86 some hours ago and I tried to update it. I ran emerge, but I received the following error:

# emerge -1p =dev-java/gjdoc-0.7.9
[... informational messages removed, nothing really important...]
!!! All ebuilds that could satisfy "=dev-java/gjdoc-0.7.9" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/gjdoc-0.7.9 (masked by: ~x86 keyword)

A quick check with eix clarified the problem:
[U] dev-java/gjdoc
     Available versions:  
			0.7.8 "amd64 ppc ppc64 x86 ~x86-fbsd" [elibc_FreeBSD source xmldoclet]
			0.7.9 "amd64 ppc ~ppc64 x86 ~x86-fbsd" [elibc_FreeBSD source xmldoclet]
		~	0.7.9[1] "~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd" [gcj xmldoclet]
		~	0.7.9-r1 "~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd" [elibc_FreeBSD source xmldoclet]
     Installed versions:  0.7.8(20:11:47 18/11/2007)(-elibc_FreeBSD -source -xmldoclet)
     Description:         A javadoc compatible Java source documentation generator.
[1] "java-overlay" /usr/portage/local/layman/java-overlay

So, it seems that Portage checks only the first ebuild that matches a given atom and does not proceed further, should that ebuild be not mergeable for some reason. I don't know if this is a bug, but is this behavior intended?

$ emerge --info
Portage 2.2_rc24 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r2 i686)
System uname: Linux-2.6.28-gentoo-r2-i686-Intel-R-_Pentium-R-_M_processor_1.60GHz-with-glibc2.0
Timestamp of tree: Tue, 10 Mar 2009 18:15:02 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.28-r1
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
EMERGE_DEFAULT_OPTS="--tree --keep-going"
FEATURES="candy distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/gnome /usr/portage/local/layman/java-overlay /usr/portage/local/layman/science /usr/local/portage"
USE="X a52 aac aalib acpi alsa amr apache2 avi bash-completion bitmap-fonts bluetooth branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt ctype cups dbus djvu dri dvd dvdr dvdread dvi emacs encode esd exif fbcon ffmpeg flac fortran ftp gd gdbm gif gimp gimpprint gnome gnome-print gnutls gpm gstreamer gtk gtk2 gtkhtml hal hddtemp iconv id3tag ipv6 java javascript jce jikes jpeg libnotify libsamplerate logrotate mad midi mikmod mmx mmxext mng mp3 mpeg msn mudflap mysql mysqli nautilus ncurses nls nodrm nptl nptlonly nsplugin offensive ogg opengl openmp oss pam pch pcre pdf perl php png posix ppds python qt3support qt4 quicktime readline samba sdl session slang sockets socks5 spell spl sse sse2 ssl startup-notification subversion svg symlink sysfs syslog tcpd theora threads tiff tokenizer truetype unicode usb v4l v4l2 vcd vorbis wifi win32codecs wmf wxwindows x86 xml xorg xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers imagemap include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="intel i810 vesa fbdev"
Comment 1 Zac Medico gentoo-dev 2009-09-16 21:18:20 UTC
I'm planning to solve this by making the dependency resolver use a separate pordbapi instance for each overlay.
Comment 2 Fabio Erculiani (RETIRED) gentoo-dev 2009-09-28 08:38:00 UTC
Adding myself to CC
Comment 3 Zac Medico gentoo-dev 2009-12-07 06:21:33 UTC
*** Bug 296017 has been marked as a duplicate of this bug. ***
Comment 4 Zac Medico gentoo-dev 2010-10-01 15:53:50 UTC
This is fixed in the master branch, by the 'reposytax' patches like this one:;a=commit;h=e92bdc4e4b955a93409f64bcc5aac5b6333234de
Comment 5 Zac Medico gentoo-dev 2010-10-06 21:16:41 UTC
This is fixed in 2.2_rc90, but I'll leave this bug open until it's in an unmasked release.
Comment 6 Marco Leogrande 2010-10-07 13:00:29 UTC
OP here.
I've just upgraded to sys-apps/portage-2.2_rc90 and my test case seems to work. Thank you :)
Comment 7 Zac Medico gentoo-dev 2011-06-06 13:06:05 UTC
This is fixed in 2.1.10.
Comment 8 Zac Medico gentoo-dev 2011-10-02 19:02:40 UTC
*** Bug 170288 has been marked as a duplicate of this bug. ***