Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 257399

Summary: [Tracker] sys-devel/libtool-2.2.6a stabilisation
Product: Gentoo Linux Reporter: Jeroen Roovers <jer>
Component: New packagesAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: normal CC: arfrever, axiator, flameeyes, gustavo, n-roeser, nicolasbock, pacho, rhill, vomacko
Priority: High Keywords: STABLEREQ, Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 212763, 281342    
Bug Blocks: 255542, 257337, 279426, 280584, 281220, 283715, 284776, 285110    
Attachments: build.log
tests-as-needed.patch
Test 63 log
testsuite.log

Description Jeroen Roovers gentoo-dev 2009-02-02 16:56:30 UTC
For eva...
Comment 1 Opportunist 2009-05-14 06:10:46 UTC
Any progress in this bug?
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-22 10:54:39 UTC
Base system: can we get libtool 2.2 stable anytime soon? The tinderbox seems to be _quite_ sane, and I'd need this for PulseAudio at least.

Thanks!
Comment 3 Samuli Suominen gentoo-dev 2009-07-30 13:30:08 UTC
+1, let's get this going..
Comment 4 Tony Vroon gentoo-dev 2009-07-30 13:43:59 UTC
Arch teams, there is confirmation that all show-stopping bugs have been cleared, and a month of time has been left for any latent bugs. Please proceed, noting dependent bug #279426 for a package that should be stabilized together with libtool.

Target stable KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86" for sys-devel/libtool-2.2.6a
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-08-01 00:25:53 UTC
Created attachment 199768 [details]
build.log

on amd64, There are 2 test failure regressions in 2.2.6a that are NOT present in 1.5.26.

28: Runpath in libtool library files                FAILED
73: Run tests with low max_cmd_len                  FAILED

As this causes the ebuild to die(), amd64 will not mark it stable until it is deemed that the failures are not a problem (hence, patched to not be executed). or the offending condition that causes the failures is remedied. thx
Comment 6 Markus Meier gentoo-dev 2009-08-01 13:53:40 UTC
(In reply to comment #5)
> 28: Runpath in libtool library files                FAILED
> 73: Run tests with low max_cmd_len                  FAILED

confirming these two failures on my system too (amd64 and x86).
Comment 7 Tobias Klausmann gentoo-dev 2009-08-10 12:38:20 UTC
Fails in exactly the same way on alpha.
Comment 8 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-01 14:42:57 UTC
(In reply to comment #7)
> Fails in exactly the same way on alpha.

 Another confirmation on x86, and maybe we can have some feedback from base-system on the issue?
Comment 9 Pacho Ramos gentoo-dev 2009-09-03 16:33:30 UTC
Under Mandriva the following is told in Changelog:
* Tue Jan 27 2009 Pixel <pixel@mandriva.com> 2.2.6-1mdv2009.1
+ Revision: 334330
- new version: 2.2.6a
...
- for the testsuite to succeed:
  o disable icrecream during the tests
  o disable ld --as-needed and --no-undefined
...

and the run tests with "ICECC=no make check"
OpenSuSE spec has the following "resolution" instead:
%check
trap 'test $? -ne 0 && cat tests/testsuite.log' EXIT
# Avoid spurious testsuite failures due to messages from icecream
PATH=/usr/bin:$PATH
make check

Maybe this could be the problem :-/
Comment 10 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-07 11:35:38 UTC
(In reply to comment #9)
> Under Mandriva the following is told in Changelog:

 Thanks for the research, I used ICECC=no and still get the tests error.
Comment 11 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-07 11:36:25 UTC
I should add: This meanwhile holds up a lot of stabilisations, especially of the newer not-security-breached GnuTLS.
Comment 12 Dustin Polke 2009-09-11 16:43:54 UTC
I found that with USE="vanilla" tests pass successfully on my stable amd64 chroot.
I then commented every line in the ! vanilla if block except the cd and the two eautoreconf to investigate further why the two mentioned tests fail.
Basically nothing is done but run eautoreconf in ${S}/libltdl and ${S}.

But...
This already brakes tests. I don't know much about autotools, but maybe someone with more knowledge can investigate further in this direction.

On a side note: I had libtool-2.6.6a installed in my testing chroot build with USE="-vanilla" and disabled tests. After upgrading readline and doing the necessary revdep-rebuild which re-emerged python, python tests failed. After downgrading libtool again, python tests were successful.
With USE="vanilla" libtool-2.2.6a, python tests pass as well.
Comment 13 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-11 19:54:42 UTC
(In reply to comment #12)
> I found that with USE="vanilla" tests pass successfully on my stable amd64
> chroot.
> I then commented every line in the ! vanilla if block except the cd and the two
> eautoreconf to investigate further why the two mentioned tests fail.
> Basically nothing is done but run eautoreconf in ${S}/libltdl and ${S}.

 I can confirm this.  No matter which eautoreconf call is used, the tests fail afterwards.  Dustin, are you willing to bring this to upstream's attention?

> But...
> This already brakes tests. I don't know much about autotools, but maybe someone
> with more knowledge can investigate further in this direction.
> 
> On a side note: I had libtool-2.6.6a installed in my testing chroot build with
> USE="-vanilla" and disabled tests. After upgrading readline and doing the
> necessary revdep-rebuild which re-emerged python, python tests failed. After
> downgrading libtool again, python tests were successful.
> With USE="vanilla" libtool-2.2.6a, python tests pass as well.
> 

Comment 14 Pacho Ramos gentoo-dev 2009-09-13 10:26:11 UTC
When eautoreconf is not run, tests 28 and 73 success, but test 37 fails for me:
 37: localized compiler messages                     FAILED (localization.at:50)
Comment 15 Pacho Ramos gentoo-dev 2009-09-13 12:01:09 UTC
(In reply to comment #11)
> I should add: This meanwhile holds up a lot of stabilisations, especially of
> the newer not-security-breached GnuTLS.
> 

Maybe this bug should depend on bug 275695 for easily seeing gnutls stabilization progress :-)
Comment 16 Dustin Polke 2009-09-13 13:51:05 UTC
(In reply to comment #13)
>  I can confirm this.  No matter which eautoreconf call is used, the tests fail
> afterwards.  Dustin, are you willing to bring this to upstream's attention?
I would prefer a dev with contact to upstream to bring this to their attention.


(In reply to comment #14)
> When eautoreconf is not run, tests 28 and 73 success, but test 37 fails for me:
>  37: localized compiler messages                     FAILED
> (localization.at:50)
> 
Is this with USE="vanilla" or have you just commented out the eautoreconf lines in the ebuild?
Comment 17 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 14:38:29 UTC
Not running elibtoolize fixes test #28 at least (committed now). The other two failures (#37 and #73) are still there.
Comment 18 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 14:39:47 UTC
Test #37 will fail for everybody without the German locale installed, just so you know…

I'd suggest skipping that test in Gentoo at least.
Comment 19 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 15:28:26 UTC
In the upstream repo the localization test is fixed so that if the German locale is not available it's skipped… I'll try to backport that one.

Comment 20 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 15:42:30 UTC
YAI! libtool 2.2.6a tests now pass fully with USE=-vanilla!

The backport to skip over test #37 when German locale is unavailable fixed #73 as well: #73 is just a recursive testsuite, so _any_ other failing tests will fail that one as well.

Stabilisation is no longer blocked; arch teams, please test and mark stable. Thanks!
Comment 21 Pacho Ramos gentoo-dev 2009-09-13 17:07:15 UTC
(In reply to comment #20)
> YAI! libtool 2.2.6a tests now pass fully with USE=-vanilla!
> 
> The backport to skip over test #37 when German locale is unavailable fixed #73
> as well: #73 is just a recursive testsuite, so _any_ other failing tests will
> fail that one as well.
> 
> Stabilisation is no longer blocked; arch teams, please test and mark stable.
> Thanks!
> 

Ups, I reported the problem upstream some hours ago, I will notify them where was the problem :-D
Comment 22 Dustin Polke 2009-09-13 19:02:57 UTC
Created attachment 203964 [details, diff]
tests-as-needed.patch

(In reply to comment #20)
> YAI! libtool 2.2.6a tests now pass fully with USE=-vanilla!
> 
> The backport to skip over test #37 when German locale is unavailable fixed #73
> as well: #73 is just a recursive testsuite, so _any_ other failing tests will
> fail that one as well.
> 
> Stabilisation is no longer blocked; arch teams, please test and mark stable.
> Thanks

Can confirm that test 28 passes now. However, with --as-needed, test 63 (and 73) fails. Should we explicitely disable --as-needed while building the tests by adding "-Wl,--no-as-needed" to LDFLAGS?
Comment 23 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 19:07:28 UTC
73 is not representative since it'll fail whenever another test fails.

 63: template test with subdirs                      ok

I can't seem to get this to fail and I obviously have --as-needed in my system, can you provide the log of how it fails please? It's inside tests/testsuite.dir/63/ .
Comment 24 Dustin Polke 2009-09-13 19:24:01 UTC
Created attachment 203967 [details]
Test 63 log
Comment 25 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 19:36:42 UTC
emerge --info please?
Comment 26 Dustin Polke 2009-09-13 19:45:17 UTC
(In reply to comment #25)
> emerge --info please?
Sorry.

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r5-stable x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-stable-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-1.12.11.1
Timestamp of tree: Sun, 13 Sep 2009 17:45:02 +0000
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -msse4.1 -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/bin/mygenkernel /usr/sbin/run-crons /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -msse4.1 -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages keeptemp multilib-strict parallel-fetch protect-owned sandbox sfperms splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://gd.tuwien.ac.at/opsys/linux/gentoo/     ftp://gentoo.inode.at/source/     ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/     ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="*"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 isdnlog mmx mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode xorg zlib" ALSA_CARDS="hda-intel mpu401" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="fuji ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="*" USERLAND="GNU
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS_FLAGS, PORTDIR_OVERLAY
Comment 27 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 20:53:28 UTC
Dustin can you please open a new bug for your failure? I have been able to confirm it with gcc 4.3 but I don't seem to be able to reproduce it on gcc 4.4, so it might not really be just --as-needed related.
Comment 28 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2009-09-13 20:56:24 UTC
Created attachment 203977 [details]
testsuite.log

The failed test with gcc 4.4.1, I hope it helps :).

zsh 1007 # emerge --info
Portage 2.2_rc40 (default/linux/amd64/10.0/desktop, gcc-4.4.1-asneeded, glibc-2.10.1-r0, 2.6.31-gentoo x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4800+-with-gentoo-2.0.1
Timestamp of tree: Sun, 13 Sep 2009 17:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests ccache collision-protect distlocks fakeroot fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms sign strict stricter suidctl unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
GENTOO_MIRRORS="http://gentoo.mneisen.org/ ftp://mirror.netcologne.de/gentoo/ http://mirror.netcologne.de/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,now -Wl,--sort-common"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/idle/dev/gentoo/overlay /usr/local/portage/layman/x11 /usr/local/portage/layman/kde-testing /usr/local/portage /home/idle/dev/gentoo/sunrise/sunrise /home/idle/dev/gentoo/perl/perl-overlay"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit 7zip X a52 aac acl akonadi alsa amarok amd64 ao archive aspell ass audio audiofile avahi bash-completion berkdb bugzilla bzip2 cairo ccache cdaudio cdda cddb cdparanoia cdr cg cleartype cli clock clucene cmake colordiff corefonts cracklib crypt cscope css ctype cuda cups curl curlwrappers cursors cxx dbus designer devhelp dga divx dmx dnsdb docbook downloadorder dri dts dv dvb dvd dvdr ebook emovix enca encode enscript eu_epg exif expat faac faad fame fbcon fbcondecor fbdev ffmpeg fftw firefox flac fontconfig fontforge foomaticdb freeimage ftp fuse gcrypt gd gdbm gecko geoip ggi gif git glade glib glibc-compat20 glitz gmedia gmp gnome gnutls gpg gpgme gpm graphviz gs gstreamer gtk gtkhtml gtkstyle hal hddtemp hdri hpn hunspell ical icons iconv icq icu id3 id3tag idn imagemagick imap imlib infowidget inherit-graph inotify ipfilter iproute2 ithreads jabber javascript jpeg kde kontact kqemu kross lame lcms libedit libevent libffi libgcrypt libmms libnotify libssh2 libv4l2 libwww linuxkeys linuxthreads-tls live logitech-mouse logrotate lzma lzo mad magic maildir mdnsresponder-compat memoryview midi mikmod mime mmap mmx mmxext mng mouse mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql ncurses net netpbm network-cron nls nntp npp nptl nptlonly nsplugin nvidia offensive ogg openal openexr opengl openmp openssl oxygen pam pango pcap pcf pch pcntl pcre pdf perl phonon physfs pixmaps plugins png pop posix prelude ps psf pth python qmake qt3support qt4 quicktime raptor rar readline realmedia recode redland replytolist rtc rtsp sasl schroedinger sdl sdl-image semantic-desktop sesame2 sha512 simplexml slang smime smp smtp sndfile sockets sound sourceview sox speex spell spl sql sqlite sqlite3 srt sse sse2 ssh ssl startup-notification stream subversion svg sysfs syslog sysvipc taglib theora threads threadsafe threadsonly tidy tiff tools tordns trayicon truetype tv_check tv_combiner unicode urandom usb userlocales utils v4l v4l2 valgrind vcd vdpau video vim-pager vim-syntax vim-with-x vorbis wav webkit wma wmf wmp wxwidgets wxwindows x264 x86emu xattr xcb xcomposite xft xine xinerama xml xmlpatterns xmlrpc xorg xosd xpm xrandr xscreensaver xterm-color xulrunner xv xvid xvmc zeroconf zip zlib zsh-completion zvbi" ALSA_CARDS="usb-audio hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol mmap_emul" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia fbdev"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 29 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 21:09:55 UTC
Now I may definitely say "fuck" because I can't reproduce it.
Comment 30 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 22:26:33 UTC
AH!! I got it! You both are using older binutils than me! (I just was able to reproduce it in the tinderbox that also uses standard binutils).

In recent binutils, --as-needed is "softer" in the indirect link case, so the problem does not appear with that.

On whether the test is right and the older --as-needed behaviour is wrong, I'm not really sure…

If you guys want to open a bug for it, it might be best, doesn't smell like a stable showstopper to me.
Comment 31 Dustin Polke 2009-09-13 22:39:01 UTC
> If you guys want to open a bug for it, it might be best, doesn't smell like a
> stable showstopper to me.
idl0r: Would you be so kind to open a bug?
All: Would it make sense to conditionally either patch tests to force no-as-needed or at least put a elog to the ebuild to inform stable users that tests fail with stable binutils?

Comment 32 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 22:42:41 UTC
I'm actually testing an einfo-ed change to add no-as-needed conditionally to the older binutils.
Comment 33 Jeroen Roovers gentoo-dev 2009-09-13 23:46:37 UTC
(In reply to comment #28)
> The failed test with gcc 4.4.1, I hope it helps :).

That's of no concern right now as libtool-2.2.6a is being stabled, and gcc-4.4* stabilisation is still a long way off.
Comment 34 Jeroen Roovers gentoo-dev 2009-09-13 23:50:42 UTC
(In reply to comment #32)
> I'm actually testing an einfo-ed change to add no-as-needed conditionally to
> the older binutils.

--as-needed isn't standard issue yet so we should now focus on stabilisation.
Comment 35 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-13 23:56:50 UTC
Jeroen, lately you seem to be quite not reading me… I said first that it wasn't a show stopper… but either way that's all taken care of so, yeah please do go on with stable marking thanks!
Comment 36 Ryan Hill (RETIRED) gentoo-dev 2009-09-14 02:05:48 UTC
a bit late now, but you guys might have searched first.
Comment 37 Christian Faulhammer (RETIRED) gentoo-dev 2009-09-14 21:11:25 UTC
x86 stable, thanks to everyone
Comment 38 Jeroen Roovers gentoo-dev 2009-09-15 01:06:39 UTC
Stable for HPPA.

(In reply to comment #35)
> Jeroen, lately you seem to be quite not reading me… I said first that it
> wasn't a show stopper… but either way that's all taken care of so, yeah
> please do go on with stable marking thanks!

I was making these comments because no one else did. Nothing happened. Now something has. Don't take it personally.
Comment 39 Gustavo Zacarias 2009-09-15 12:33:46 UTC
How about adding a notice to the libtool ebuild that revdep-rebuild needs to be run after upgrading?
This broke imagemagick, php, openldap and nagios-core on one of my servers, and i noticed because being an ex-dev i know devs are sometimes sloppy.
Comment 40 Olivier Crete (RETIRED) gentoo-dev 2009-09-15 16:34:51 UTC
Thanks flameeyes, amd64 done
Comment 41 Markus Meier gentoo-dev 2009-09-19 13:59:46 UTC
arm stable
Comment 42 Samuli Suominen gentoo-dev 2009-09-19 14:02:09 UTC
(In reply to comment #39)
> How about adding a notice to the libtool ebuild that revdep-rebuild needs to be
> run after upgrading?
> This broke imagemagick, php, openldap and nagios-core on one of my servers, and
> i noticed because being an ex-dev i know devs are sometimes sloppy.

It's not a job for the ebuild to print out (useless) messages, it's been fixed in Portage 2.2_rc* by preserved-libs feature.
Comment 43 SpanKY gentoo-dev 2009-09-19 15:12:37 UTC
yes, but those versions arent stable.  i was hoping a version of portage would be stable by the time libtool-2 went stable which is why i didnt use preserve lib stuff in the first place.

http://sources.gentoo.org/sys-devel/libtool/libtool-2.2.6a.ebuild?r1=1.12&r2=1.13
Comment 44 nixnut (RETIRED) gentoo-dev 2009-09-20 19:32:49 UTC
ppc stable
Comment 45 Brent Baude (RETIRED) gentoo-dev 2009-09-27 00:56:23 UTC
ppc64 done
Comment 46 Tobias Klausmann gentoo-dev 2009-09-29 17:13:54 UTC
Stable on alpha.
Comment 47 Raúl Porcel (RETIRED) gentoo-dev 2009-10-13 17:25:22 UTC
ia64/m68k/s390/sh/sparc stable, closing