Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 209416

Summary: [TRACKER] >=sys-libs/slang-2.1.3 incompatible packages
Product: Gentoo Linux Reporter: Samuli Suominen <ssuominen>
Component: New packagesAssignee: Samuli Suominen <ssuominen>
Status: VERIFIED FIXED    
Severity: normal CC: cjk, fauli, flameeyes, jakub, maintainer-needed, martin, media-video, net-news, wschlich
Priority: High Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 198859, 203672    
Bug Blocks:    

Description Samuli Suominen gentoo-dev 2008-02-09 05:54:59 UTC
These ebuilds depend on =sys-libs/slang-1* or such but to allow unmask of slang 2.1.3 latest versions of these ebuilds need to be checked with 2.1.3, might work out of box.

app-editors/fte
app-admin/partgui
app-backup/mondo-rescue
app-editors/jed
app-editors/nano
app-emulation/dosemu
app-misc/mc
app-mobilephone/yaps
app-shells/pdmenu
dev-libs/newt
dev-util/biew
games-emulation/advancemenu
media-libs/aalib
media-libs/libcaca
media-radio/tucnak1
media-sound/timidity++
media-video/freej
net-analyzer/nettop
net-analyzer/trafshow
net-misc/tn5250
net-nntp/slrn
sci-libs/gaul-devel
sys-apps/most
sys-block/partimage
Comment 1 Samuli Suominen gentoo-dev 2008-02-09 05:56:34 UTC
*** Bug 141947 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2008-02-09 06:18:48 UTC
CC some maintainers to help with testing. If the app fails with slang 2.1.3 open a bug blocking this one, thanks..
Comment 3 Samuli Suominen gentoo-dev 2008-02-09 06:43:17 UTC
media-libs/aalib
media-libs/libcaca
media-radio/tucnak1

fixed or checked.
Comment 4 Ulrich Müller gentoo-dev 2008-02-09 09:17:14 UTC
> app-editors/jed

Fixed.
Comment 5 Samuli Suominen gentoo-dev 2008-02-09 10:59:24 UTC
sys-apps/most fixed
Comment 6 Samuli Suominen gentoo-dev 2008-02-09 11:09:21 UTC
dev-util/biew fixed
Comment 7 Samuli Suominen gentoo-dev 2008-02-09 11:31:44 UTC
dev-libs/newt and app-admin/partgui fixed
Comment 8 Samuli Suominen gentoo-dev 2008-02-09 11:42:23 UTC
app-shells/pdmenu and app-misc/mc checked or fixed
Comment 9 Samuli Suominen gentoo-dev 2008-02-09 11:45:46 UTC
app-editors/nano is fine wrt bug #203672
Comment 10 Samuli Suominen gentoo-dev 2008-02-09 12:05:51 UTC
app-editors/fte and net-analyzer/nettop fixed
Comment 11 Samuli Suominen gentoo-dev 2008-02-09 12:24:07 UTC
net-analyzer/trafshow and app-mobilephone/yaps fixed
Comment 12 Samuli Suominen gentoo-dev 2008-02-09 12:51:54 UTC
games-emulation/advancemenu and app-emulation/dosemu checked or fixed
Comment 13 Samuli Suominen gentoo-dev 2008-02-09 13:05:25 UTC
sys-block/partimage fixed
Comment 14 Samuli Suominen gentoo-dev 2008-02-09 13:07:47 UTC
These are left:

net-misc/tn5250
sci-libs/gaul-devel
media-sound/timidity++
media-video/freej
app-backup/mondo-rescue
net-nntp/slrn
Comment 15 Samuli Suominen gentoo-dev 2008-02-09 13:30:07 UTC
(In reply to comment #14)
> These are left:
> 
> net-misc/tn5250
> sci-libs/gaul-devel

Both had USE slang, added -r1 without one as temp. solution.

> media-sound/timidity++

Seems to be fine with slang 2.1.3, fixed in -r6.

> media-video/freej

No clue, can't build it on ~amd64.

> app-backup/mondo-rescue

Hardmasked for other reasons

> net-nntp/slrn

Broken

Unmasking slang

Comment 16 Markus Dittrich (RETIRED) gentoo-dev 2008-02-09 16:58:51 UTC
I backported slang-2 to sci-libs/gaul-devel and re-added
the slang keyword.

media-libs/libcaca currently breaks for me on x86 during
configure with USE="slang" and may hence need some
additional fixing

checking slang.h usability... no
checking slang.h presence... no
checking for slang.h... no
checking slang/slang.h usability... no
checking slang/slang.h presence... no
checking for slang/slang.h... no
configure: error: cannot find slang development files

thanks,
Markus
Comment 17 Markus Dittrich (RETIRED) gentoo-dev 2008-02-09 17:29:57 UTC
My bad, I guess I was accidentally using slang-2.1.2.
Hence, please ignore my above post.

Markus
Comment 18 Samuli Suominen gentoo-dev 2008-02-10 09:55:31 UTC
slrn maintainers, if it's OK to you I'd like to switch to Debian patchset which is including support for slang-2. i'd just like to see this bug go away asap..

removing sci@ from CC since gaul-devel is now really fixed and slang support restored
Comment 19 Samuli Suominen gentoo-dev 2008-02-11 13:16:17 UTC
- slrn fixed
- freej and mondo-rescue are both hardmasked and has their own bugs

considering as fixed, closing
Comment 20 Martin Väth 2008-03-10 17:04:49 UTC
I do not understand why this bug is considered as fixed:

Since slang is not slotted anymore but e.g. advancemame still depends on
=sys-libs/slang-1*, there are now incompatible dependencies pulled in on
an x86 system since slang-2* is stable (if advancemame is installed).
Comment 21 Samuli Suominen gentoo-dev 2008-03-10 17:59:25 UTC
(In reply to comment #20)
> I do not understand why this bug is considered as fixed:
> 
> Since slang is not slotted anymore but e.g. advancemame still depends on
> =sys-libs/slang-1*, there are now incompatible dependencies pulled in on
> an x86 system since slang-2* is stable (if advancemame is installed).
> 

:(

Got it confused with advancemenu when doing testing. Follow up advancemame on bug 212960, thanks!