Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 141947 - Please fix the dependencies on slang-1*
Summary: Please fix the dependencies on slang-1*
Status: RESOLVED DUPLICATE of bug 209416
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: CJK Team
URL:
Whiteboard:
Keywords:
: 182310 185988 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-07-27 16:05 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2008-02-09 05:56 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2006-07-27 16:05:36 UTC
As slang-2 is going to be added to portage as slot 2, please fix the dependencies so that stuff depends on slang 1.4, as the two versions aren't API compatible.

Involved ebuilds:

app-admin/partgui-0.2.3-r2
app-backup/mondo-rescue-1.47
app-backup/mondo-rescue-1.61
app-backup/mondo-rescue-1.65
app-backup/mondo-rescue-2.03
app-backup/mondo-rescue-2.04
app-backup/mondo-rescue-2.10
app-editors/jed-0.99.16-r2
app-editors/lpe-1.2.6
app-editors/lpe-1.2.6.12
app-editors/nano-1.2.5
app-editors/nano-1.3.11-r2
app-editors/nano-1.3.12-r1
app-emulation/dosemu-1.2.2-r1
app-emulation/dosemu-1.3.2
app-misc/mc-4.6.1
app-misc/mc-4.6.1-r1
app-misc/slmon-0.5.13
app-mobilephone/yaps-0.96-r1
dev-libs/newt-0.50.35-r4
dev-libs/newt-0.51.6
dev-libs/newt-0.51.6-r1
dev-perl/Newt-1.08
dev-util/biew-5.5.0
dev-util/biew-5.6.1
dev-util/biew-5.6.2
games-emulation/advancemame-0.104.0
games-emulation/advancemenu-2.4.12
games-emulation/advancemenu-2.4.13
mail-client/mutt-1.4.2.1
mail-client/mutt-1.5.8-r1
mail-client/mutt-1.5.8-r2
mail-client/mutt-1.5.9
mail-client/muttng-20060329
mail-client/muttng-20060415
mail-client/muttng-20060619
mail-client/muttng-20060619-r1
media-libs/libcaca-0.9-r1
media-libs/libcaca-0.9-r2
media-radio/tucnak1-1.22
media-sound/timidity++-2.13.2
media-sound/timidity++-2.13.2-r2
net-analyzer/nettop-0.2.3
net-analyzer/trafshow-4.0
net-analyzer/trafshow-5.2.1
net-analyzer/trafshow-5.2.3
net-misc/tn5250-0.16.5
net-nntp/slrn-0.9.8.1
sci-libs/gaul-devel-0.1846
sys-apps/most-4.10.2-r1
sys-apps/most-4.9.2
sys-apps/most-4.9.4
sys-apps/most-4.9.5
sys-block/partimage-0.6.4-r3
sys-block/partimage-0.6.4-r4
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-07-27 16:35:23 UTC
timidity and libcaca fixed.
Comment 2 Christian Zoffoli (RETIRED) gentoo-dev 2006-07-27 16:41:54 UTC
newt and partimage fixed
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-07-27 16:51:31 UTC
mc and tn5250 fixed too.
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2006-07-27 18:07:51 UTC
games fixed.
Comment 5 Stefan Briesenick (RETIRED) gentoo-dev 2006-07-27 18:17:58 UTC
yaps fixed.
Comment 6 Daniel Black (RETIRED) gentoo-dev 2006-07-27 23:44:28 UTC
netmon done:
net-analyzer/nettop
net-analyzer/trafshow
Comment 7 Alastair Tse (RETIRED) gentoo-dev 2006-07-28 02:06:05 UTC
app-editors/jed done
Comment 8 Fabian Groffen gentoo-dev 2006-07-28 02:29:19 UTC
muttng done
Comment 9 Hanno Böck gentoo-dev 2006-07-28 08:03:11 UTC
dosemu done
Comment 10 Michael Cummings (RETIRED) gentoo-dev 2006-07-29 17:27:41 UTC
dev-perl/Newt done, removing perl herd.
Comment 11 SpanKY gentoo-dev 2006-07-30 13:00:21 UTC
nano needs slang-2 ;P
Comment 12 Michal Januszewski (RETIRED) gentoo-dev 2006-08-08 14:14:28 UTC
biew done.
Comment 13 Fernando J. Pereda (RETIRED) gentoo-dev 2006-08-14 10:58:35 UTC
Fixed mail-client/mutt

- ferdy
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2007-02-04 02:44:46 UTC
>=sys-apps/most-4.10 supports slang2.  earlier versions have been fixed.

removing shell-tools.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-02-08 08:09:08 UTC
What's left?

app-admin/partgui - phosphan
app-backup/mondo-rescue - wschlich (been p.masked for ages, noone cares)
app-editors/lpe - pyrania (MIA)
app-misc/slmon - ka0ttic (being retired)
net-nntp/slrn - net-news
sci-libs/gaul-devel - sci
Comment 16 Sven Wegener gentoo-dev 2007-02-08 23:34:40 UTC
net-nntp/slrn done
Comment 17 Christian Faulhammer (RETIRED) gentoo-dev 2007-06-08 06:30:28 UTC
emacs team takes over app-editors/jed, I will have to go into that, too.
Comment 18 SpanKY gentoo-dev 2007-06-17 21:08:29 UTC
*** Bug 182310 has been marked as a duplicate of this bug. ***
Comment 19 Christian Faulhammer (RETIRED) gentoo-dev 2007-06-18 07:09:38 UTC
app-editors/jed done, removing emacs team

Should we force changing the other ebuilds now?
Comment 20 Patrick Kursawe (RETIRED) gentoo-dev 2007-07-17 08:57:53 UTC
Sorry, partgui fixed. I have no idea how I was able to not notice this Cc: for a year. Maybe a bit too quick at the delete button...
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 14:05:49 UTC
*** Bug 185988 has been marked as a duplicate of this bug. ***
Comment 22 Jeffrey Gardner (RETIRED) gentoo-dev 2007-07-20 18:47:23 UTC
sci-libs/gaul-devel done
Comment 23 Vladimir G. Ivanovic 2007-10-24 19:07:19 UTC
What's left?

app-backup/mondo-rescue - wschlich (been p.masked for ages, no one cares)
app-editors/lpe         - pyrania (MIA)
app-misc/slmon          - ka0ttic (being retired)

So, is it appropriate to mask app-editors/lpe and app-misc/slmon instead of holding back slang-2*?

Comment 24 Wolfram Schlich (RETIRED) gentoo-dev 2008-01-23 08:49:45 UTC
(In reply to comment #23)
> What's left?
> 
> app-backup/mondo-rescue - wschlich (been p.masked for ages, no one cares)

Ok, I just realized I am still in metadata.xml :]
Will try to proxy-maintain mondo-rescue now if the developer is still
willing to provide ebuilds. Sorry for the delay...
Comment 25 Christian Faulhammer (RETIRED) gentoo-dev 2008-01-23 08:51:25 UTC
(In reply to comment #23)
> So, is it appropriate to mask app-editors/lpe and app-misc/slmon instead of
> holding back slang-2*?

 I asked wschlich to take care of mondorescue in some way, while I contacted treecleaners on lpe and slmon (adding them to cc here, too).
Comment 26 Samuli Suominen gentoo-dev 2008-01-24 11:07:49 UTC
(In reply to comment #25)
> (In reply to comment #23)
> > So, is it appropriate to mask app-editors/lpe and app-misc/slmon instead of
> > holding back slang-2*?
> 
>  I asked wschlich to take care of mondorescue in some way, while I contacted
> treecleaners on lpe and slmon (adding them to cc here, too).
> 

Treecleaners can hand it, yes. Any objections from members?
Comment 27 Samuli Suominen gentoo-dev 2008-01-24 11:12:12 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #23)
> > > So, is it appropriate to mask app-editors/lpe and app-misc/slmon instead of
> > > holding back slang-2*?
> > 
> >  I asked wschlich to take care of mondorescue in some way, while I contacted
> > treecleaners on lpe and slmon (adding them to cc here, too).
> > 
> 
> Treecleaners can hand it, yes. Any objections from members?
> 

Actually, why is app-editors/lpe a problem here, it should work with slang-2 and it can also be version bumped:

http://packages.debian.org/sid/lpe

so -1 for it's removal.
Comment 28 Christian Faulhammer (RETIRED) gentoo-dev 2008-01-24 11:35:31 UTC
(In reply to comment #27)
> Actually, why is app-editors/lpe a problem here, it should work with slang-2
> and it can also be version bumped:

  Will bump and test it.
Comment 29 Samuli Suominen gentoo-dev 2008-01-24 11:50:06 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > Actually, why is app-editors/lpe a problem here, it should work with slang-2
> > and it can also be version bumped:
> 
>   Will bump and test it.
> 

heh, sorry.. did that already :)
Comment 30 Samuli Suominen gentoo-dev 2008-01-24 11:55:50 UTC
same as slmon.. works with slang-2, no reason to remove it unless it's broken anyway? http://packages.debian.org/fi/sid/slmon

nothing for treecleaners here.. not touching this one now, so feel free to fix (i'll do it later if noone else will)
Comment 31 Samuli Suominen gentoo-dev 2008-01-24 19:05:52 UTC
done,

slmon-0.5.13 depends now on =sys-libs/slang-1*.
slmon-0.5.13-r1 depends now on >=sys-libs/slang-2 and is masked with slang-2.

this entire slang slotting is _ridicilous_, most apps work fine out of box with slang-2 but we rename it as libslang-2.so and install the header to slang-2/slang.h..

it should have been handled differently.
Comment 32 Samuli Suominen gentoo-dev 2008-02-09 05:56:34 UTC

*** This bug has been marked as a duplicate of bug 209416 ***