Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 1797

Summary: irda-utils broken
Product: Gentoo Linux Reporter: simon <csimonut>
Component: [OLD] UnspecifiedAssignee: Peter Johanson (RETIRED) <latexer>
Status: RESOLVED FIXED    
Severity: normal CC: brianr, cadik60070, rigo, st_lim
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Updated .ebuild to go with the gentoo-patch
Patch to add gentoo-specific /etc files to irda-utils
/etc/init.d/irda

Description simon 2002-04-15 04:46:03 UTC
I've tried to install irda-utils-0.9.13 on Gentoo-Linux 1.0 (upgraded to 1.1a, I
hope so ;-).

The location and style of init/config-scripts for irda don't fit in the
gentoo-layout, looks like my old redhat.

files get placed in:
/etc/rc.d/init.d
/etc/sysconfig
...
and refers to missing files (/etc/rc.d/init.d/functions, ...)

Simon
Comment 1 Brian Rozmierski 2002-06-25 14:18:03 UTC
I've done some work on this problem, first off using the (newer) 0.9.14 source,
I've updated the .ebuild file and added a patch to add the proper gentoo files
(1 each in /etc/conf.d and /etc/init.d) to the source tree.

I'm still wrestling my IR on my notebook, so testing will have to be tried by
someone else :) (Hint: _Always_ build IrDA support as modules -- irattach has a
fit if you don't)

There are a few questions I had/have that perhaps someone more knowledgable can
answer.

First, the patch only adds 2 files. I wasn't sure if we wanted to clutter-up the
portage */*/files directory with them, or version-specific patch files instead.
Easy to fix either way.

Second, the old .ebuild has a line in unpack() to change autoconf version
information. I have removed that because it seems to compile just fine either
way. If there was a reason this was done that escapes me, feel free to
un-comment it in the ebuild file. (Or if you have problems compiling - I'm using
1.3a ATM)

In any case, please take a good look over the changes/additions and let me know
if this works for you.
Comment 2 Brian Rozmierski 2002-06-25 14:19:18 UTC
Created attachment 1777 [details]
Updated .ebuild to go with the gentoo-patch
Comment 3 Brian Rozmierski 2002-06-25 14:20:11 UTC
Created attachment 1778 [details, diff]
Patch to add gentoo-specific /etc files to irda-utils
Comment 4 Lapo Calamandrei 2002-08-06 06:46:30 UTC
Created attachment 2860 [details]
/etc/init.d/irda

corrected the usage of start-stop-daemon, now the service start and stop
correctly.
Comment 5 simon 2002-11-01 09:39:56 UTC
Wanted to test the changes, but I can't find irda-utils-0.9.14 or something like
that in portage tree or cvs. Or do I have to get the ebuild an patches from the
attachements?

Am I missing something?

Simon
Comment 6 Chad Huneycutt (RETIRED) gentoo-dev 2002-12-15 12:46:51 UTC
Okay, guys, thanks for the updates.  I have (finally) committed 0.9.15 with your
changes and some others.  Please try it out, and let me know how it works.
Comment 7 Chad Huneycutt (RETIRED) gentoo-dev 2002-12-15 12:51:14 UTC
*** Bug 6494 has been marked as a duplicate of this bug. ***
Comment 8 Chad Huneycutt (RETIRED) gentoo-dev 2002-12-15 15:41:38 UTC
*** Bug 8452 has been marked as a duplicate of this bug. ***
Comment 9 simon 2002-12-16 13:22:58 UTC
Thank you, it works (for me ;o)  bea portage # irdadump  19:18:51.296924 xid:cmd d26657f8 > ffffffff S=6 s=0 (14)  19:18:51.386914 xid:cmd d26657f8 > ffffffff S=6 s=1 (14)  19:18:51.476916 xid:cmd d26657f8 > ffffffff S=6 s=2 (14)  19:18:51.566913 xid:cmd d26657f8 > ffffffff S=6 s=3 (14)  19:18:51.656913 xid:cmd d26657f8 > ffffffff S=6 s=4 (14)  19:18:51.746910 xid:cmd d26657f8 > ffffffff S=6 s=5 (14)  19:18:51.836914 xid:cmd d26657f8 > ffffffff S=6 s=* bea hint=0400 [ Computer ] (19)  19:18:54.296924 xid:cmd d26657f8 > ffffffff S=6 s=0 (14)  19:18:54.386912 xid:cmd d26657f8 > ffffffff S=6 s=1 (14)  19:18:54.476914 xid:cmd d26657f8 > ffffffff S=6 s=2 (14)  19:18:54.566912 xid:cmd d26657f8 > ffffffff S=6 s=3 (14)  19:18:54.656908 xid:cmd d26657f8 > ffffffff S=6 s=4 (14)  19:18:54.749892 xid:rsp d26657f8 < 7d17c103 S=6 s=4 xxxxxxxxx xxxxxxxxx hint=8220 [ PDA/Palmtop IrOBEX ] (36)   emerged irda-utils-0.9.15, set the correct device in /etc/conf.d/irda and  started /etc/init.d/irda.  The modules irda and irtty were loaded automatic. after loading ircomm and ircomm-tty I could sync my Sony Clie with jpilot-sync (/dev/ircomm0).  I have not tried to get this working for my normal user (get Permission denied) or with FIR and so on. But it is just for my Clie and connection to Internet via cell, so speed does not matter.  There are still (useless) files in /etc/sysconfig/.  Thank you very much, Simon 
Comment 10 simon 2002-12-16 14:04:46 UTC
Hi, 
 
Added 
# irda 
irda 
irtty 
ircomm 
ircomm-tty 
to /etc/modules.autoload 
 
added a group irda 
irda::28:simon 
 
and /etc/devfs.d/irda 
REGISTER        ^ircomm*        PERMISSIONS root.irda 660 
 
simon@bea simon $ ls -al /dev/ircomm0  
crw-rw----    1 root     irda     161,   0 Dec 16 20:58 /dev/ircomm0 
 
Don't know if that is the "correct" or best way to do that or if the gid is 
normally occupied by someone else. But it works for me. 
 
Simon 
Comment 11 Chad Huneycutt (RETIRED) gentoo-dev 2002-12-16 17:23:24 UTC
Simon, I am guessing the /etc/sysconfig stuff is left over from a previous
ebuild.  It should be safe to remove it (if it all just irda stuff).  The ebuild
shouldn't be installing anything there now, though.


Your devfs settings look like exactly the way to go.  I'll see about adding them.
Comment 12 Ted Baker 2003-04-15 09:07:22 UTC
The files in /etc/sysconfig are still being written with v0.9.15

I'm happy to test any changes - I'm running gNokii with a Nokia 6310i phone.

Philip
Comment 13 Karl Trygve Kalleberg (RETIRED) gentoo-dev 2003-06-14 08:49:42 UTC
Actually, 0.9.15 does install both /etc/sysconfig and /etc/rc.d stuff, as can be gleaned from /var/db/pkg/sys-apps/irda-tools-0.9.15/CONTENTS
Comment 14 Aron Griffis (RETIRED) gentoo-dev 2004-01-17 10:03:57 UTC
The script install-etc installs files in /etc/sysconfig if that directory exists on the system.  I put a fix in the ebuild for this, which I think closes this bug.