Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 897968 (CVE-2023-23627) - <dev-ruby/sanitize-6.0.1: XSS vulnerability
Summary: <dev-ruby/sanitize-6.0.1: XSS vulnerability
Alias: CVE-2023-23627
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Security
Whiteboard: ~3 [noglsa]
Depends on:
Reported: 2023-02-26 18:29 UTC by John Helmert III
Modified: 2023-08-02 05:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2023-02-26 18:29:34 UTC

Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. The default configurations do not allow `noscript` elements and are not vulnerable. This issue only affects users who are using a custom config that adds `noscript` to the element allowlist. This issue has been patched in version 6.0.1. Users who are unable to upgrade can prevent this issue by using one of Sanitize's default configs or by ensuring that their custom config does not include `noscript` in the element allowlist.

Please cleanup <6.0.1.
Comment 1 Hans de Graaff gentoo-dev Security 2023-07-22 04:56:08 UTC
commit 56b2444f4c6d196272a9e935f97e3b3d646b3f55
Author: Sam James <>
Date:   Fri Mar 31 01:29:28 2023 +0100

    dev-ruby/sanitize: drop 6.0.0
    Signed-off-by: Sam James <>
Comment 2 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2023-08-02 05:43:47 UTC
Thank you! All done.