Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 879617 (CVE-2022-43548) - <net-libs/nodejs-{14.21.1,16.18.1,18.12.1}: multiple vulnerabilities
Summary: <net-libs/nodejs-{14.21.1,16.18.1,18.12.1}: multiple vulnerabilities
Status: IN_PROGRESS
Alias: CVE-2022-43548
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://nodejs.org/en/blog/vulnerabil...
Whiteboard: B2 [glsa?]
Keywords:
: 880259 (view as bug list)
Depends on: 880795
Blocks: CVE-2022-3602, CVE-2022-3786
  Show dependency tree
 
Reported: 2022-11-04 19:14 UTC by John Helmert III
Modified: 2022-12-13 21:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-11-04 19:14:57 UTC
No details yet, but the CVE is released and 14.21.1,
16.18.1, and 19.0.1 are released. Please bump.
Comment 1 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-11-07 22:26:35 UTC
*** Bug 880259 has been marked as a duplicate of this bug. ***
Comment 2 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-11-10 16:15:51 UTC
18.12.1 released too.
Comment 3 Larry the Git Cow gentoo-dev 2022-11-10 18:31:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c37bf12bae13bb8c8a8d59302aa85e55b84b8f6e

commit c37bf12bae13bb8c8a8d59302aa85e55b84b8f6e
Author:     William Hubbs <williamh@gentoo.org>
AuthorDate: 2022-11-10 18:31:21 +0000
Commit:     William Hubbs <williamh@gentoo.org>
CommitDate: 2022-11-10 18:31:34 +0000

    net-libs/nodejs: add 14.21.1, 16.18.1, 18.12.1
    
    Bug: https://bugs.gentoo.org/879617
    Closes: https://bugs.gentoo.org/879615
    Signed-off-by: William Hubbs <williamh@gentoo.org>

 net-libs/nodejs/Manifest              |   3 +
 net-libs/nodejs/nodejs-14.21.1.ebuild | 241 ++++++++++++++++++++++++++++++++
 net-libs/nodejs/nodejs-16.18.1.ebuild | 233 +++++++++++++++++++++++++++++++
 net-libs/nodejs/nodejs-18.12.1.ebuild | 251 ++++++++++++++++++++++++++++++++++
 4 files changed, 728 insertions(+)
Comment 4 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-12-10 01:48:23 UTC
Please cleanup
Comment 5 Larry the Git Cow gentoo-dev 2022-12-12 20:25:09 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f158ff4a2df632cf9cd15d900502ca74abce7f55

commit f158ff4a2df632cf9cd15d900502ca74abce7f55
Author:     William Hubbs <williamh@gentoo.org>
AuthorDate: 2022-12-12 20:23:44 +0000
Commit:     William Hubbs <williamh@gentoo.org>
CommitDate: 2022-12-12 20:24:34 +0000

    net-libs/nodejs: drop 14.20.1, 16.17.1, 16.18.0, 18.10.0, 18.11.0
    
    Bug: https://bugs.gentoo.org/879617
    Signed-off-by: William Hubbs <williamh@gentoo.org>

 net-libs/nodejs/Manifest              |   5 -
 net-libs/nodejs/nodejs-14.20.1.ebuild | 241 --------------------------------
 net-libs/nodejs/nodejs-16.17.1.ebuild | 233 -------------------------------
 net-libs/nodejs/nodejs-16.18.0.ebuild | 232 -------------------------------
 net-libs/nodejs/nodejs-18.10.0.ebuild | 251 ----------------------------------
 net-libs/nodejs/nodejs-18.11.0.ebuild | 250 ---------------------------------
 6 files changed, 1212 deletions(-)
Comment 6 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-12-13 21:53:20 UTC
Thanks!