Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 878763 (CVE-2022-41973, CVE-2022-41974) - <sys-fs/multipath-tools-0.9.3: multiple vulnerabilities
Summary: <sys-fs/multipath-tools-0.9.3: multiple vulnerabilities
Status: IN_PROGRESS
Alias: CVE-2022-41973, CVE-2022-41974
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL: http://www.openwall.com/lists/oss-sec...
Whiteboard: B1 [glsa? cleanup]
Keywords:
Depends on: 882869 883759 883807
Blocks:
  Show dependency tree
 
Reported: 2022-10-30 01:26 UTC by John Helmert III
Modified: 2022-12-01 07:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-10-30 01:26:23 UTC
CVE-2022-41973 (https://bugzilla.suse.com/show_bug.cgi?id=1202739):

multipath-tools 0.7.7 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited in conjunction with CVE-2022-41974. Local users able to access /dev/shm can change symlinks in multipathd due to incorrect symlink handling, which could lead to controlled file writes outside of the /dev/shm directory. This could be used indirectly for local privilege escalation to root.

CVE-2022-41974 (https://bugzilla.suse.com/show_bug.cgi?id=1202739):

multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.

Please bump to 0.9.2.
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-10-30 21:32:38 UTC
'Reference' is not a valid GLEP 66 tag so the bot didn't tag the bug.

commit 9199809d660b52e6f4e960fc1bea889bea15cdaa
Author: Robin H. Johnson <robbat2@gentoo.org>
Date:   Sat Oct 29 21:35:20 2022 -0700

    sys-fs/multipath-tools: bump

    Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
    Reference: https://bugs.gentoo.org/show_bug.cgi?id=878763

commit 4035f35583fab2b3f22c09d2f2894f4b8f20cee0
Author: Robin H. Johnson <robbat2@gentoo.org>
Date:   Sat Oct 29 20:10:43 2022 -0700

    sys-fs/multipath-tools: bump

    Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
    Reference: https://bugs.gentoo.org/show_bug.cgi?id=878763
Comment 2 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-12-01 00:50:26 UTC
Please cleanup.