Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 834802 (CVE-2022-24714, CVE-2022-24715, CVE-2022-24716) - <www-apps/icingaweb2-2.9.6: multiple vulnerabilities
Summary: <www-apps/icingaweb2-2.9.6: multiple vulnerabilities
Status: CONFIRMED
Alias: CVE-2022-24714, CVE-2022-24715, CVE-2022-24716
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B1 [glsa?]
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-09 01:25 UTC by John Helmert III
Modified: 2022-05-10 16:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-03-09 01:25:12 UTC
CVE-2022-24714 (https://github.com/Icinga/icingaweb2/security/advisories/GHSA-qcmg-vr56-x9wf):

Icinga Web 2 is an open source monitoring web interface, framework and command-line interface. Installations of Icinga 2 with the IDO writer enabled are affected. If you use service custom variables in role restrictions, and you regularly decommission service objects, users with said roles may still have access to a collection of content. Note that this only applies if a role has implicitly permitted access to hosts, due to permitted access to at least one of their services. If access to a host is permitted by other means, no sensible information has been disclosed to unauthorized users. This issue has been resolved in versions 2.8.6, 2.9.6 and 2.10 of Icinga Web 2.

CVE-2022-24715 (https://github.com/Icinga/icingaweb2/security/advisories/GHSA-v9mv-h52f-7g63):

Icinga Web 2 is an open source monitoring web interface, framework and command-line interface. Authenticated users, with access to the configuration, can create SSH resource files in unintended directories, leading to the execution of arbitrary code. This issue has been resolved in versions 2.8.6, 2.9.6 and 2.10 of Icinga Web 2. Users unable to upgrade should limit access to the Icinga Web 2 configuration.

CVE-2022-24716 (https://github.com/Icinga/icingaweb2/security/advisories/GHSA-5p3f-rh28-8frw):

Icinga Web 2 is an open source monitoring web interface, framework and command-line interface. Unauthenticated users can leak the contents of files of the local system accessible to the web-server user, including `icingaweb2` configuration files with database credentials. This issue has been resolved in versions 2.9.6 and 2.10 of Icinga Web 2. Database credentials should be rotated.


Fixes in 2.9.6, please bump.
Comment 1 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2022-05-10 14:46:46 UTC
only 2.10.0 and 2.10.1 remain in tree