Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 836001 (CVE-2022-1061, CVE-2022-1240, CVE-2022-1244) - [Tracker] Multiple vulnerabilities in radare2/rizin
Summary: [Tracker] Multiple vulnerabilities in radare2/rizin
Status: CONFIRMED
Alias: CVE-2022-1061, CVE-2022-1240, CVE-2022-1244
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://huntr.dev/bounties/a7546dae-0...
Whiteboard:
Keywords:
Depends on: 836002 CVE-2021-4021, CVE-2022-0139, CVE-2022-0173, CVE-2022-0476, CVE-2022-0518, CVE-2022-0519, CVE-2022-0520, CVE-2022-0521, CVE-2022-0522, CVE-2022-0523, CVE-2022-0559, CVE-2022-0695, CVE-2022-0712, CVE-2022-0713, CVE-2022-1237, CVE-2022-1238, CVE-2022-1283, CVE-2022-1284, CVE-2022-1296, CVE-2022-1297, CVE-2022-1382, CVE-2022-1383, CVE-2022-1437
Blocks:
  Show dependency tree
 
Reported: 2022-03-25 14:16 UTC by John Helmert III
Modified: 2022-04-12 16:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-03-25 14:16:20 UTC
CVE-2022-1061:

Heap Buffer Overflow in parseDragons in GitHub repository radareorg/radare2 prior to 5.6.8.

radare2 patch: https://github.com/radareorg/radare2/commit/d4ce40b516ffd70cf2e9e36832d8de139117d522
Comment 1 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-04-12 16:20:10 UTC
Two more: 

CVE-2022-1240 (https://huntr.dev/bounties/e589bd97-4c74-4e79-93b5-0951a281facc):

Heap buffer overflow in libr/bin/format/mach0/mach0.c in GitHub repository radareorg/radare2 prior to 5.8.6. If address sanitizer is disabled during the compiling, the program should executes into the `r_str_ncpy` function. Therefore I think it is very likely to be exploitable. For more general description of heap buffer overflow, see [CWE](https://cwe.mitre.org/data/definitions/122.html).

CVE-2022-1244 (https://huntr.dev/bounties/8ae2c61a-2220-47a5-bfe8-fe6d41ab1f82):

heap-buffer-overflow in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is capable of inducing denial of service.