Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786561 (CVE-2021-31863, CVE-2021-31864, CVE-2021-31865, CVE-2021-31866) - www-apps/redmine: Multiple vulnerabilities (CVE-2021-{31863,31864,31865,31866})
Summary: www-apps/redmine: Multiple vulnerabilities (CVE-2021-{31863,31864,31865,31866})
Status: IN_PROGRESS
Alias: CVE-2021-31863, CVE-2021-31864, CVE-2021-31865, CVE-2021-31866
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: ~3 [ebuild]
Keywords:
Depends on: 787533 787539
Blocks:
  Show dependency tree
 
Reported: 2021-04-28 21:19 UTC by Sam James
Modified: 2021-07-29 18:11 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James archtester gentoo-dev Security 2021-04-28 21:19:45 UTC
* CVE-2021-31866

Description:
"Redmine before 4.0.9 and 4.1.x before 4.1.3 allows an attacker to learn the values of internal authentication keys by observing timing differences in string comparison operations within SysController and MailHandlerController."

* CVE-2021-31865

Description:
"Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows users to circumvent the allowed filename extensions of uploaded attachments."

* CVE-2021-31864

Description:
"Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows attackers to bypass the add_issue_notes permission requirement by leveraging the incoming mail handler."

* CVE-2021-31863

Description::
"Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process."
Comment 1 Azamat H. Hackimov 2021-05-05 16:39:04 UTC
I need rails 5.2.5 and roadie-rails 2.2.0 for version bump, please fix #787533 and #787539 issues.
Comment 2 P. Roth 2021-07-10 17:08:09 UTC
While waiting for the Ruby Team to fix #787533, would upgrading to 4.1.3 first be viable? Maybe not ideal, but it's out now for 2.5 months...
Comment 3 NATTkA bot gentoo-dev 2021-07-29 17:22:39 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2021-07-29 17:30:56 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2021-07-29 17:38:53 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2021-07-29 17:47:02 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2021-07-29 18:03:00 UTC Comment hidden (obsolete)
Comment 8 NATTkA bot gentoo-dev 2021-07-29 18:11:18 UTC
Package list is empty or all packages have requested keywords.