Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 782706 (CVE-2020-18971, CVE-2020-18972, CVE-2021-30469, CVE-2021-30470, CVE-2021-30471, CVE-2021-30472) - app-text/podofo: multiple vulnerabilities (CVE-2020-{18971,18972}, CVE-2021-{30469,30470,30471,30472})
Summary: app-text/podofo: multiple vulnerabilities (CVE-2020-{18971,18972}, CVE-2021-{...
Status: IN_PROGRESS
Alias: CVE-2020-18971, CVE-2020-18972, CVE-2021-30469, CVE-2021-30470, CVE-2021-30471, CVE-2021-30472
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://sourceforge.net/p/podofo/tick...
Whiteboard: B2 [upstream]
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-13 19:03 UTC by Sam James
Modified: 2021-08-25 19:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James archtester gentoo-dev Security 2021-04-13 19:03:42 UTC
"Stack-Overflow in PdfEncrypt.cpp"

Upstream report: https://sourceforge.net/p/podofo/tickets/132/
Comment 1 Sam James archtester gentoo-dev Security 2021-05-26 23:58:44 UTC
* CVE-2021-30470

Description:
"A flaw was found in PoDoFo 0.9.7. An uncontrolled recursive call among PdfTokenizer::ReadArray(), PdfTokenizer::GetNextVariant() and PdfTokenizer::ReadDataType() functions can lead to a stack overflow."

https://sourceforge.net/p/podofo/tickets/130/

* CVE-2021-30471

Description:
"A flaw was found in PoDoFo 0.9.7. An uncontrolled recursive call in PdfNamesTree::AddToDictionary function in src/podofo/doc/PdfNamesTree.cpp can lead to a stack overflow."

https://sourceforge.net/p/podofo/tickets/131/

* CVE-2021-30469

Description:
"A flaw was found in PoDoFo 0.9.7. An use-after-free in PoDoFo::PdfVecObjects::Clear() function can cause a denial of service via a crafted PDF file."

https://sourceforge.net/p/podofo/tickets/129/
Comment 2 NATTkA bot gentoo-dev 2021-07-29 17:23:09 UTC Comment hidden (obsolete)
Comment 3 NATTkA bot gentoo-dev 2021-07-29 17:31:29 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2021-07-29 17:39:26 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2021-07-29 17:47:36 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2021-07-29 18:03:32 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2021-07-29 18:11:51 UTC
Package list is empty or all packages have requested keywords.
Comment 8 John Helmert III gentoo-dev Security 2021-08-25 19:16:42 UTC
CVE-2020-18971 (https://sourceforge.net/p/podofo/tickets/48/):

Stack-based Buffer Overflow in PoDoFo v0.9.6 allows attackers to cause a denial of service via the component 'src/base/PdfDictionary.cpp:65'.

CVE-2020-18972 (https://sourceforge.net/p/podofo/tickets/49/):

Exposure of Sensitive Information to an Unauthorized Actor in PoDoFo v0.9.6 allows attackers to obtain sensitive information via 'IsNextToken' in the component 'src/base/PdfToenizer.cpp'.

Seems there's some confusion about the validity of both of these.