Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 743205 (CVE-2019-20917, CVE-2019-20918, CVE-2020-25269) - <net-irc/inspircd-{2.0.29, 3.6.0}: Multiple vulnerabilities (CVE-2019-{20917,20918}, CVE-2020-25269)
Summary: <net-irc/inspircd-{2.0.29, 3.6.0}: Multiple vulnerabilities (CVE-2019-{20917,...
Status: IN_PROGRESS
Alias: CVE-2019-20917, CVE-2019-20918, CVE-2020-25269
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [glsa? cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-17 23:47 UTC by Sam James
Modified: 2020-09-17 23:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James archtester gentoo-dev Security 2020-09-17 23:47:19 UTC
* CVE-2019-20917

Description:
"An issue was discovered in InspIRCd 2 before 2.0.28 and 3 before 3.3.0. The mysql module contains a NULL pointer dereference when built against mariadb-connector-c 3.0.5 or newer. When combined with the sqlauth or sqloper modules, this vulnerability can be used for remote crashing of an InspIRCd server by any user able to connect to a server. "

Links:
https://docs.inspircd.org/security/2019-02/
https://github.com/inspircd/inspircd/commit/2cc35d8625b7ea5cbd1d1ebb116aff86c5280162
https://github.com/inspircd/inspircd/commit/8745660fcdac7c1b80c94cfc0ff60928cd4dd4b7 

* CVE-2019-20918

Description:
"An issue was discovered in InspIRCd 3 before 3.1.0. The silence module contains a use after free vulnerability. This vulnerability can be used for remote crashing of an InspIRCd server by any user able to fully connect to a server."

Links:
https://docs.inspircd.org/security/2019-01/
https://github.com/inspircd/inspircd/commit/7b47de3c194f239c5fea09a0e49696c9af017d51
https://github.com/inspircd/inspircd/commit/bcd65de1ec4bb71591ae417fee649d7ecd37cd57 

* CVE-2020-25269

Description:
"An issue was discovered in InspIRCd 2 before 2.0.29 and 3 before 3.6.0. The pgsql module contains a use after free vulnerability. When combined with the sqlauth or sqloper modules, this vulnerability can be used for remote crashing of an InspIRCd server by any user able to connect to a server."

Links:
https://docs.inspircd.org/security/2020-01/
https://github.com/inspircd/inspircd/compare/426d1c8...b3f1db9
https://github.com/inspircd/inspircd/compare/v2.0.28...07d7dea
Comment 1 Sam James archtester gentoo-dev Security 2020-09-17 23:47:41 UTC
These bugs are resolved in tree but this is for possible GLSA purposes. No need for maintainer action.