Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 719146 (CVE-2019-17571, CVE-2020-9488, CVE-2020-9493, CVE-2022-23302, CVE-2022-23305) - dev-java/log4j: Multiple vulnerabilities
Summary: dev-java/log4j: Multiple vulnerabilities
Status: IN_PROGRESS
Alias: CVE-2019-17571, CVE-2020-9488, CVE-2020-9493, CVE-2022-23302, CVE-2022-23305
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B2 [ebuild cve]
Keywords:
Depends on: 829192
Blocks:
  Show dependency tree
 
Reported: 2020-04-24 02:08 UTC by GLSAMaker/CVETool Bot
Modified: 2022-01-19 02:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GLSAMaker/CVETool Bot gentoo-dev 2020-04-24 02:08:27 UTC
CVE-2019-17571 (https://nvd.nist.gov/vuln/detail/CVE-2019-17571):
  Included in Log4j 1.2 is a SocketServer class that is vulnerable to
  deserialization of untrusted data which can be exploited to remotely execute
  arbitrary code when combined with a deserialization gadget when listening to
  untrusted network traffic for log data. This affects Log4j versions up to
  1.2 up to 1.2.17.


Patch: https://src.fedoraproject.org/rpms/log4j12/c/d4c817c458d69dcc629a7271999d178b0dcb7c74?branch=master

Note from Debian [0]:
"CVE-2019-17571 correspond to CVE-2017-5645 for apache-log4j2. 1.2.x branch
is end-of-life upstream and does not recieve a fix for this issue. Users
should upgrade to Log4j 2.x."

[0] https://security-tracker.debian.org/tracker/CVE-2019-17571
Comment 1 GLSAMaker/CVETool Bot gentoo-dev 2020-04-27 18:47:01 UTC
CVE-2020-9488 (https://nvd.nist.gov/vuln/detail/CVE-2020-9488):
  Improper validation of certificate with host mismatch in Apache Log4j SMTP
  appender. This could allow an SMTPS connection to be intercepted by a
  man-in-the-middle attack which could leak any log messages sent through that
  appender.
Comment 2 John Helmert III gentoo-dev Security 2022-01-19 02:44:18 UTC
CVE-2022-23302:

JMSSink in all versions of Log4j 1.x is vulnerable to deserialization of untrusted data when the attacker has write access to the Log4j configuration or if the configuration references an LDAP service the attacker has access to. The attacker can provide a TopicConnectionFactoryBindingName configuration causing JMSSink to perform JNDI requests that result in remote code execution in a similar fashion to CVE-2021-4104. Note this issue only affects Log4j 1.x when specifically configured to use JMSSink, which is not the default. Apache Log4j 1.2 reached end of life in August 2015. Users should upgrade to Log4j 2 as it addresses numerous other issues from the previous versions.

CVE-2022-23305:

By design, the JDBCAppender in Log4j 1.2.x accepts an SQL statement as a configuration parameter where the values to be inserted are converters from PatternLayout. The message converter, %m, is likely to always be included. This allows attackers to manipulate the SQL by entering crafted strings into input fields or headers of an application that are logged allowing unintended SQL queries to be executed. Note this issue only affects Log4j 1.x when specifically configured to use the JDBCAppender, which is not the default. Beginning in version 2.0-beta8, the JDBCAppender was re-introduced with proper support for parameterized SQL queries and further customization over the columns written to in logs. Apache Log4j 1.2 reached end of life in August 2015. Users should upgrade to Log4j 2 as it addresses numerous other issues from the previous versions.

CVE-2020-9493 (http://www.openwall.com/lists/oss-security/2022/01/18/5):

A deserialization flaw was found in Apache Chainsaw versions prior to 2.1.0 which could lead to malicious code execution.