Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 670036 (CVE-2018-14644) - <net-dns/pdns-recursor-4.1.5: multiple vulnerabilities (CVE-2018-{10851,14626,14644})
Summary: <net-dns/pdns-recursor-4.1.5: multiple vulnerabilities (CVE-2018-{10851,14626...
Status: RESOLVED FIXED
Alias: CVE-2018-14644
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [noglsa cve]
Keywords:
Depends on: CVE-2018-10851, CVE-2018-14626
Blocks:
  Show dependency tree
 
Reported: 2018-10-31 15:07 UTC by Thomas Deutschmann
Modified: 2018-11-23 23:16 UTC (History)
1 user (show)

See Also:
Package list:
net-dns/pdns-recursor-4.1.7
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev Security 2018-10-31 15:07:10 UTC
Incoming details.
Comment 1 Sven Wegener gentoo-dev 2018-11-06 22:31:17 UTC
Upstream has released the new version: https://blog.powerdns.com/2018/11/06/powerdns-authoritative-server-4-0-6-4-1-5-and-recursor-4-0-9-4-1-5-released/

I committed 4.1.5 to the tree and it's ready to go stable.
Comment 2 Thomas Deutschmann gentoo-dev Security 2018-11-06 22:40:09 UTC
Crafted zone record can cause a denial of service
=================================================
- CVE: CVE-2018-10851
- Date: November 6th 2018
- Affects: PowerDNS Authoritative from 3.3.0 up to and including 4.1.4
- Not affected: 4.1.5, 4.0.6
- Severity: Medium
- Impact: Denial of service
- Exploit: This problem can be triggered via crafted records
- Risk of system compromise: No
- Solution: Upgrade to a non-affected version
- Workaround: run the process inside the guardian or inside a supervisor

An issue has been found in PowerDNS Authoritative Server allowing an authorized user to cause a memory leak by inserting a specially crafted record in a zone under their control, then sending a DNS query for that record. The issue is due to the fact that some memory is allocated before the parsing and is not always properly released if the record is malformed.

This issue has been assigned CVE-2018-10851.

When the PowerDNS Authoritative Server is run inside the guardian (--guardian), or inside a supervisor like supervisord or systemd, an out-of-memory crash will lead to an automatic restart, limiting the impact to a somewhat degraded service.

PowerDNS Authoritative from 3.3.0 up to and including 4.1.4 is affected. Please note that at the time of writing, PowerDNS Authoritative 3.4 and below are no longer supported, as described in End of life statements.


Packet cache pollution via crafted query
========================================
- CVE: CVE-2018-14626
- Date: November 6th 2018
- Affects: PowerDNS Authoritative from 4.1.0 up to and including 4.1.4
- Not affected: 4.1.5, 4.0.x
- Severity: Medium
- Impact: Denial of service
- Exploit: This problem can be triggered via crafted queries
- Risk of system compromise: No
- Solution: Upgrade to a non-affected version

An issue has been found in PowerDNS Authoritative Server allowing a remote user to craft a DNS query that will cause an answer without DNSSEC records to be inserted into the packet cache and be returned to clients asking for DNSSEC records, thus hiding the presence of DNSSEC signatures for a specific qname and qtype. For a DNSSEC-signed domain, this means that DNSSEC validating clients will consider the answer to be bogus until it expires from the packet cache, leading to a denial of service.

This issue has been assigned CVE-2018-14626.

PowerDNS Authoritative from 4.1.0 up to and including 4.1.4 is affected.

We would like to thank Kees Monshouwer for finding and subsequently reporting this issue.
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-11-07 10:24:48 UTC
amd64 stable
Comment 4 Thomas Deutschmann gentoo-dev Security 2018-11-07 23:45:52 UTC
x86 stable
Comment 5 Sven Wegener gentoo-dev 2018-11-09 16:46:22 UTC
I've committed and stabilized the new 4.1.7, which contains a different fix for CVE-2018-14644 with relaxed EDNS compliance requirements.
Comment 6 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2018-11-23 23:16:26 UTC
GLSA Vote: No