Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 616870 (CVE-2017-8309) - <app-emulation/qemu-2.9.0-r1: audio: host memory lekage via capture buffer
Summary: <app-emulation/qemu-2.9.0-r1: audio: host memory lekage via capture buffer
Status: RESOLVED FIXED
Alias: CVE-2017-8309
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: B4 [glsa cve]
Keywords:
Depends on: CVE-2017-8380
Blocks:
  Show dependency tree
 
Reported: 2017-04-28 13:19 UTC by Agostino Sarubbo
Modified: 2017-06-06 06:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2017-04-28 13:19:21 UTC
From ${URL} :

Quick Emulator(Qemu) built with the Audio subsystem support is vulnerable to
a host memory leakage issue. It could occur if a guest user was to repeatedly
start and stop audio capture.

A privileged user inside guest could use this flaw to exhaust host memory,
resulting in DoS.

Upstream patch:
---------------
  -> https://lists.gnu.org/archive/html/qemu-devel/2017-04/msg05587.html


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Matthias Maier gentoo-dev 2017-04-29 21:33:59 UTC
commit ea97b0c7b7466e74a67ad714b07509c752f5870c
Author: Matthias Maier <tamiko@gentoo.org>
Date:   Sat Apr 29 16:01:30 2017 -0500

    app-emulation/qemu: Various security patches for 2.9.0
    
    bug 616636, CVE-2017-8112
    bug 616870 [1]
    bug 616872 [2]
    bug 616874 [1]
    
    [1] minor change, queued upstream, no CVE assigned yet
    [2] queued upstream, no CVE assigned yet
    
    Package-Manager: Portage-2.3.3, Repoman-2.3.2
Comment 2 Yury German Gentoo Infrastructure gentoo-dev Security 2017-05-21 07:46:46 UTC
Added to an existing GLSA Request.
Comment 3 GLSAMaker/CVETool Bot gentoo-dev 2017-06-06 06:50:03 UTC
This issue was resolved and addressed in
 GLSA 201706-03 at https://security.gentoo.org/glsa/201706-03
by GLSA coordinator Yury German (BlueKnight).