Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 633734 (CVE-2017-14849) - net-libs/nodejs-8.5.0 path traversal vulnerability (CVE-2017-14849)
Summary: net-libs/nodejs-8.5.0 path traversal vulnerability (CVE-2017-14849)
Alias: CVE-2017-14849
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Security
Whiteboard: ~4 [noglsa cve]
Depends on:
Reported: 2017-10-08 01:59 UTC by thomasg
Modified: 2020-04-17 03:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description thomasg 2017-10-08 01:59:37 UTC
The nodejs 8.x series before 8.6 is vulnerable to a path traversal attack, as described in CVE-2017-14849.
Upstream has fixed the issue in the 8.6.0 release, which has been available for over a week.
Comment 1 Christopher Díaz Riveros (RETIRED) gentoo-dev Security 2017-10-08 17:20:01 UTC
@Maintainer could you please verify which versions in tree are vulnerable?

As stated in URL:

4.x NOT vulnerable (stable)
6.x NOT vulnerable (stable)
7.x unknown (non-stable)
8.x unknown (non-stable)
8.5.0 is vulnerable (non-stable)

Thank you,

Gentoo Security Padawan
Comment 2 Jonas Stein gentoo-dev 2017-10-30 00:18:08 UTC
whoops. Sorry.
Comment 3 Aaron Bauman (RETIRED) gentoo-dev 2017-10-30 00:43:29 UTC
ebuild and cleanup?
Comment 4 Christopher Díaz Riveros (RETIRED) gentoo-dev Security 2017-10-30 01:04:09 UTC
Now everything is fixed and tree is clean. Closing

Thank you