Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 596046 (CVE-2016-7800) - <media-gfx/graphicsmagick-1.3.26: 8BIM/8BIMW unsigned underflow leads to heap overflow
Summary: <media-gfx/graphicsmagick-1.3.26: 8BIM/8BIMW unsigned underflow leads to heap...
Status: RESOLVED FIXED
Alias: CVE-2016-7800
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: B3 [noglsa cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-03 14:51 UTC by Agostino Sarubbo
Modified: 2017-10-23 00:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2016-10-03 14:51:21 UTC
From ${URL} :

An unsigned overflow leading to heap buffer overflow vulnerability was found in GraphicsMagick 8BIM reader. A maliciously crafted file could cause the 
application to crash.

References:

http://seclists.org/oss-sec/2016/q4/0

Upstream patch:

https://sourceforge.net/p/graphicsmagick/code/ci/5c7b6d6094a25e99c57f8b18343914ebfd8213ef


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Christopher Díaz Riveros (RETIRED) gentoo-dev Security 2017-07-20 17:12:33 UTC
From URL:

Upstream already patched the problem for version 1.3.26

https://sourceforge.net/p/graphicsmagick/code/ci/5c7b6d6094a25e99c57f8b18343914ebfd8213ef/

@Maintainers: could you please let us know when the 1.3.26 ebuild is going to be stable

thanks
Comment 2 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2017-10-23 00:11:24 UTC
GLSA Vote: No

Cleanup tracked in bug #631562