Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 600190 (CVE-2016-6331, CVE-2016-6332, CVE-2016-6333, CVE-2016-6334, CVE-2016-6335, CVE-2016-6336, CVE-2016-6337) - <www-apps/mediawiki-1.27.1: multiple vulnerabilities
Summary: <www-apps/mediawiki-1.27.1: multiple vulnerabilities
Status: RESOLVED FIXED
Alias: CVE-2016-6331, CVE-2016-6332, CVE-2016-6333, CVE-2016-6334, CVE-2016-6335, CVE-2016-6336, CVE-2016-6337
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://lists.wikimedia.org/pipermail...
Whiteboard: B3 [noglsa cve]
Keywords:
Depends on:
Blocks: 563636 CVE-2015-8622, CVE-2015-8623, CVE-2015-8624, CVE-2015-8625, CVE-2015-8626, CVE-2015-8627, CVE-2015-8628
  Show dependency tree
 
Reported: 2016-11-18 20:10 UTC by Thomas Deutschmann
Modified: 2017-02-19 14:17 UTC (History)
1 user (show)

See Also:
Package list:
=www-apps/mediawiki-1.27.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev Security 2016-11-18 20:10:30 UTC
From $URL:

I would like to announce the release of MediaWiki 1.27.1, 1.26.4, 1.23.15!

These releases fix five security issues in core and one for the extension
PdfHandler. Download links are given at the end of this email.

== Security fixes ==

* (T139565) API: Generate head items in the context of the given title
(CVE-2016-6335)
* (T137264) XSS in unclosed internal links (CVE-2016-6334)
* (T133147) Escape '<' and ']]>' in inline <style> blocks (CVE-2016-6333)
* (T133147) Require login to preview user CSS pages (CVE-2016-6333)
* (T132926) Do not allow undeleting a revision deleted file if it is the
top file (CVE-2016-6336)
* (T129738) Make $wgBlockDisablesLogin also restrict logged in permissions
(CVE-2016-6332)
* (T129738) Make blocks log users out if $wgBlockDisablesLogin is true
(CVE-2016-6332)
* (T115333) Check read permission when loading page content in ApiParse
(CVE-2016-6331)
* (T57548) Remove support for $wgWellFormedXml = false, all output is now
well formed

The following only affects 1.27 and above and is not included in the 1.26
and 1.23 upgrade:
* (T139670) Move 'UserGetRights' call before application of
Session::getAllowedUserRights() (CVE-2016-6337)

The following fix is for the PdfHandler extension:
* (T136402) Add -dSAFER to ghostscript as hardening measure

== Release notes ==

Full release notes for 1.27.1:
<https://www.mediawiki.org/wiki/Release_notes/1.27>

Full release notes for 1.26.4:
<https://www.mediawiki.org/wiki/Release_notes/1.26>

Full release notes for 1.23.15:
<https://www.mediawiki.org/wiki/Release_notes/1.23>

For information about how to upgrade, see
<https://www.mediawiki.org/wiki/Manual:Upgrading>
Comment 1 Thomas Deutschmann gentoo-dev Security 2016-11-18 20:13:22 UTC
v1.27.1 is already in the Gentoo repository:

https://gitweb.gentoo.org/repo/gentoo.git/commit/www-apps/mediawiki?id=8103e969f43ae4daf1845d37e0cec7fcbb4575bb


@ Maintainer(s): Please tell us if we can stabilize =www-apps/mediawiki-1.27.1
Comment 2 Thomas Deutschmann gentoo-dev Security 2016-11-29 00:28:32 UTC
@ Arches,

please test and mark stable: =www-apps/mediawiki-1.27.1
Comment 3 Agostino Sarubbo gentoo-dev 2016-11-29 11:23:23 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2016-11-29 11:24:25 UTC
x86 stable
Comment 5 Agostino Sarubbo gentoo-dev 2017-01-15 16:03:42 UTC
ppc stable.

Maintainer(s), please cleanup.
Security, please vote.
Comment 6 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2017-01-16 03:41:08 UTC
GLSA Vote: No

tree is clean