Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 574418 (CVE-2016-2086, CVE-2016-2216) - <net-libs/nodejs-{0.12.10,4.4.0}: two vulnerabilities (CVE-2016-{2086,2216})
Summary: <net-libs/nodejs-{0.12.10,4.4.0}: two vulnerabilities (CVE-2016-{2086,2216})
Alias: CVE-2016-2086, CVE-2016-2216
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
Whiteboard: B3 [noglsa cve]
Depends on:
Reported: 2016-02-11 11:19 UTC by Agostino Sarubbo
Modified: 2016-12-02 08:33 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2016-02-11 11:19:16 UTC

A request smuggling vulnerability was found in Node.js that can be exploited under certain 
unspecified circumstances.

External Reference:


It was reported that HTTP header parsing in Node.js is vulnerable to response splitting attacks. While Node.js has been protecting against response splitting attacks by checking for CRLF characters, it is possible to compose response headers using Unicode 
characters that decompose to these characters, bypassing the checks previously in place.

External Reference:

@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Johan Bergström 2016-02-11 11:25:27 UTC
Update from maintainer (by proxy):

One of these vulnerabilities actually lives in net-libs/http-parser which was bumped to 2.6.1 Yesterday.

net-libs/nodejs-5.6.0 is work in progress; an ebuild sent for review (to proxies) available here:

"Unfortunately" we also have to bump 0.10, 0.12, and the LTS 4.x series. I will be reviewing these ebuilds the coming days. http-parser might not be releasing stable series for each of these so I will have to review that it works as intended before we bump.

If anyone wants more information about these vulnerabilities, feel free to contact me privately.
Comment 2 Patrick Lauer gentoo-dev 2016-02-11 12:08:48 UTC
ebuild for both http-parser-2.6.1 and nodejs-5.6.0 are in tree.
Comment 3 Pacho Ramos gentoo-dev 2016-05-17 15:16:50 UTC
Does 4.4.1 fix this? (it should be stabilized in bug 568900 it seems)
Comment 4 Thomas Deutschmann (RETIRED) gentoo-dev 2016-11-29 21:26:35 UTC
@ Arches,

please test and mark stable: =net-libs/nodejs-0.12.10
Comment 5 Agostino Sarubbo gentoo-dev 2016-12-01 12:52:03 UTC
amd64 stable
Comment 6 Agostino Sarubbo gentoo-dev 2016-12-01 12:54:43 UTC
x86 stable.

Maintainer(s), please cleanup.
Security, please vote.
Comment 7 GLSAMaker/CVETool Bot gentoo-dev 2016-12-02 08:30:27 UTC
CVE-2016-2216 (
  The HTTP header parsing code in Node.js 0.10.x before 0.10.42, 0.11.6
  through 0.11.16, 0.12.x before 0.12.10, 4.x before 4.3.0, and 5.x before
  5.6.0 allows remote attackers to bypass an HTTP response-splitting
  protection mechanism via UTF-8 encoded Unicode characters in the HTTP
  header, as demonstrated by %c4%8d%c4%8a.

CVE-2016-2086 (
  Node.js 0.10.x before 0.10.42, 0.12.x before 0.12.10, 4.x before 4.3.0, and
  5.x before 5.6.0 allow remote attackers to conduct HTTP request smuggling
  attacks via a crafted Content-Length HTTP header.
Comment 8 Aaron Bauman (RETIRED) gentoo-dev 2016-12-02 08:33:49 UTC
Proxy-maint package... tree is clean:

GLSA Vote: No