Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 636392 (CVE-2016-10209) - <app-arch/libarchive-3.3.1: Denial of service vulnerability (CVE-2016-10209)
Summary: <app-arch/libarchive-3.3.1: Denial of service vulnerability (CVE-2016-10209)
Status: RESOLVED FIXED
Alias: CVE-2016-10209
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [noglsa cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-03 15:34 UTC by GLSAMaker/CVETool Bot
Modified: 2018-08-14 20:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GLSAMaker/CVETool Bot gentoo-dev 2017-11-03 15:34:03 UTC
CVE-2016-10209 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-10209):
  The archive_wstring_append_from_mbs function in archive_string.c in
  libarchive 3.2.2 allows remote attackers to cause a denial of service (NULL
  pointer dereference and application crash) via a crafted archive file.
Comment 1 Christopher Díaz Riveros (RETIRED) gentoo-dev Security 2017-11-03 15:34:49 UTC
@Maintainers please confirm if we are affected by this, in that case, call for stabilization when ready.

Thank you
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-01-02 13:17:59 UTC
FWICS the current stable 3.3.1 includes the fix and 3.2* has been cleaned up.
Comment 3 Thomas Deutschmann gentoo-dev Security 2018-08-14 20:18:48 UTC
Repository is clean, all done.