Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 564472 (CVE-2015-7812) - app-emulation/xen-{tools-,pvgrub-}{4.2.5-r12,4.5.2}: multiple vulnerabilities (XSA-{145,146,147,148,149,150,151,152,153}) (CVE-2015-{7812,7813,7814,7835,7969,7970,7971,7972})
Summary: app-emulation/xen-{tools-,pvgrub-}{4.2.5-r12,4.5.2}: multiple vulnerabilities...
Status: RESOLVED FIXED
Alias: CVE-2015-7812
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B1 [glsa cve]
Keywords:
Depends on: CVE-2015-8339
Blocks:
  Show dependency tree
 
Reported: 2015-10-30 08:18 UTC by Agostino Sarubbo
Modified: 2016-04-05 07:01 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2015-11-04 15:42:12 UTC
All patches acquired and runtested which includes xsa142-4.5.patch for xen-tools and xsa141.patch for xen.
xsa142-4.6.patch is found to already be incorporated in the version xen-4.6.0.

Patches I hace concatenated into 2 files, however dlan assures he will packge and upload them tomorrow. Considering no urgency, holding off committing until he packages them.
Comment 2 Yixun Lan gentoo-dev 2015-11-05 07:57:26 UTC
Arches, please test and mark stable:
=app-emulation/xen-4.2.5-r12
=app-emulation/xen-tools-4.2.5-r11
Target keywords Both : "amd64 x86"

=app-emulation/xen-4.5.2
=app-emulation/xen-tools-4.5.2
=app-emulation/xen-pvgrub-4.5.2
Target keywords Only: "amd64"
Comment 3 Agostino Sarubbo gentoo-dev 2015-11-10 08:51:00 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2015-11-10 08:56:36 UTC
x86 stable.

Maintainer(s), please cleanup.
Security, please add it to the existing request, or file a new one.
Comment 5 Yury German Gentoo Infrastructure gentoo-dev 2015-12-08 00:20:04 UTC
Please cleanup den-tools, pvgrub
Comment 6 Yury German Gentoo Infrastructure gentoo-dev 2015-12-08 00:20:52 UTC
Added to an existing GLSA Request.
Comment 7 Yury German Gentoo Infrastructure gentoo-dev 2015-12-23 14:23:29 UTC
Please drop or mask xen-tools-4.2.5-{r10,r11} as was done with xen.
Comment 8 Ian Delaney (RETIRED) gentoo-dev 2016-01-17 07:28:55 UTC
(In reply to Yury German from comment #7)
> Please drop or mask xen-tools-4.2.5-{r10,r11} as was done with xen.

Thiswas done several days ago now
Comment 9 Tomoatsu Shimada 2016-02-02 06:00:27 UTC
Please forgive me if this is wrong place to discuss about this matter, but I wonder if dropping xen 4.2 has been intentionally done knowing that  it's the only version of xen which still supports x86-32 architecture.
Comment 10 Kristian Fiskerstrand (RETIRED) gentoo-dev 2016-02-02 08:29:23 UTC
(In reply to Tomoatsu Shimada from comment #9)
> Please forgive me if this is wrong place to discuss about this matter, but I
> wonder if dropping xen 4.2 has been intentionally done knowing that  it's
> the only version of xen which still supports x86-32 architecture.

This security bug is not the place to discuss it as you correctly mention; but the quick answer is I'm aware of discussions amongst Xen members on that topic so it was done with an awareness of that.
Comment 11 Tomoatsu Shimada 2016-02-02 12:31:35 UTC
Your valuable answer encouraged me to abandon x86-32 architecture,  thanks a lot!
Comment 12 Yury German Gentoo Infrastructure gentoo-dev 2016-02-25 08:28:45 UTC
Maintainer(s), Thank you for your work.
Comment 13 GLSAMaker/CVETool Bot gentoo-dev 2016-04-05 07:01:15 UTC
This issue was resolved and addressed in
 GLSA 201604-03 at https://security.gentoo.org/glsa/201604-03
by GLSA coordinator Yury German (BlueKnight).