Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 502966 (CVE-2014-1695) - <www-apps/otrs-4.0.12: Unspecified Script Insertion Vulnerability (CVE-2014-1695)
Summary: <www-apps/otrs-4.0.12: Unspecified Script Insertion Vulnerability (CVE-2014-1...
Status: RESOLVED FIXED
Alias: CVE-2014-1695
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Security
URL: https://secunia.com/advisories/57018/
Whiteboard: ~4 [noglsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-27 13:32 UTC by Agostino Sarubbo
Modified: 2016-03-29 07:49 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-02-27 13:32:54 UTC
From ${URL} :

Description

A vulnerability has bee reported in OTRS Help Desk, which can be exploited by malicious people to conduct 
script insertion attacks.

Certain input related to HTML emails is not properly sanitised before being used. This can be exploited to 
insert arbitrary HTML and script code, which will be executed in a user's browser session in context of an 
affected site when the malicious data is being viewed after following a specially crafted link.

The vulnerability is reported in versions prior to 3.1.20, 3.2.15, and 3.3.5.


Solution:
Update to version 3.1.20, 3.2.15, or 3.3.5.

Provided and/or discovered by:
Adam Ziaja.

Original Advisory:
OTRS:
https://www.otrs.com/security-advisory-2014-03-xss-issue/

Adam Ziaja:
http://adamziaja.com/


@maintainer(s): since the package has never been marked as stable, we don't need to stabilize it. After the bump, please remove the affected versions from the tree.
Comment 1 GLSAMaker/CVETool Bot gentoo-dev 2014-04-10 21:43:45 UTC
CVE-2014-1695 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1695):
  Cross-site scripting (XSS) vulnerability in Open Ticket Request System
  (OTRS) 3.1.x before 3.1.20, 3.2.x before 3.2.15, and 3.3.x before 3.3.5
  allows remote attackers to inject arbitrary web script or HTML via a crafted
  HTML email.
Comment 2 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-03-29 07:49:18 UTC
No vulnerable versions in tree.