Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 495222 (CVE-2013-7203) - <dev-vcs/gitolite-3.5.3.1: world writable files for fresh installs
Summary: <dev-vcs/gitolite-3.5.3.1: world writable files for fresh installs
Status: RESOLVED FIXED
Alias: CVE-2013-7203
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: B3 [noglsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-24 12:02 UTC by Agostino Sarubbo
Modified: 2016-11-19 04:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-12-24 12:02:09 UTC
From ${URL} :

Gitolite was found to be vulnerable to local filesystem information leak, where it could create 
world writable files in the repositories (particularly the gitolite-admin one) depending on the 
user umask running gitolite setup.

http://seclists.org/oss-sec/2013/q4/542


@maintainer(s): since the fixed package is already in the tree, please let us know if it is ready for the stabilization or not.
Comment 1 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2014-01-11 01:56:54 UTC
I haven't used 3.x so far but I think it should be ok to stabilize 3.5.3.1.
Comment 2 Alex Xu (Hello71) 2014-04-08 01:30:04 UTC
I don't think this applies to us, since the only 3.x version in tree is ~.
Comment 3 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-07-02 04:53:48 UTC
Additional information:

https://github.com/sitaramc/gitolite/commit/3dad4f8e3214d6ab5f71823019a624fa48b055a3
Comment 4 Thomas Deutschmann gentoo-dev Security 2016-11-19 02:15:26 UTC
This was fixed when https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-vcs/gitolite/gitolite-3.5.3.1.ebuild?hideattic=0&view=log hit the tree.

@ Security: Please vote!
Comment 5 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-11-19 04:28:15 UTC
Vulnerable code is not present in 2.3.1.