Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 504494 (CVE-2013-4496) - <net-fs/samba-{3.6.23,4.0.16,4.1.6}: Password Dictionary Attack Issue (CVE-2013-4496)
Summary: <net-fs/samba-{3.6.23,4.0.16,4.1.6}: Password Dictionary Attack Issue (CVE-20...
Status: RESOLVED FIXED
Alias: CVE-2013-4496
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://www.samba.org/samba/security/...
Whiteboard: B3 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-13 16:33 UTC by Brian Evans
Modified: 2015-02-26 08:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Evans Gentoo Infrastructure gentoo-dev 2014-03-13 16:33:50 UTC
From ${URL}:


Summary:     In Samba's SAMR server we neglect to ensure that
attempted password changes will update the bad password
count, nor set the lockout flags.
This would allow a user unlimited attempts against the
password by simply calling ChangePasswordUser2
repeatedly.

This is available without any other authentication.


Description: 

Samba versions 3.4.0 and above allow the administrator to implement
locking out Samba accounts after a number of bad password attempts.

However, all released versions of Samba did not implement this check for
password changes, such as are available over multiple SAMR and RAP
interfaces, allowing password guessing attacks.

As this was found during an internal audit of the Samba code there are
no currently known exploits for this problem (as of March 11th 2014).
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2014-03-14 09:30:43 UTC
+*samba-4.1.6 (14 Mar 2014)
+*samba-4.0.16 (14 Mar 2014)
+*samba-3.6.23 (14 Mar 2014)
+
+  14 Mar 2014; Lars Wendler <polynomial-c@gentoo.org> -samba-3.6.19.ebuild,
+  -samba-3.6.20.ebuild, -samba-3.6.21.ebuild, +samba-3.6.23.ebuild,
+  -samba-4.0.15-r1.ebuild, +samba-4.0.16.ebuild, -samba-4.1.5-r1.ebuild,
+  +samba-4.1.6.ebuild, files/3.6/samba.initd:
+  Security bump (bug #504494). Removed old.
+

Arches please test and mark stable =net-fs/samba-3.6.23 with target KEYWORDS:

alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux
Comment 2 Agostino Sarubbo gentoo-dev 2014-03-15 13:16:19 UTC
amd64 stable
Comment 3 Agostino Sarubbo gentoo-dev 2014-03-15 13:16:42 UTC
x86 stable
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-03-16 02:01:29 UTC
Stable for HPPA.
Comment 5 Agostino Sarubbo gentoo-dev 2014-03-16 11:11:32 UTC
ppc stable
Comment 6 Agostino Sarubbo gentoo-dev 2014-03-18 16:12:18 UTC
ia64 stable
Comment 7 Markus Meier gentoo-dev 2014-03-22 21:37:10 UTC
arm stable
Comment 8 Agostino Sarubbo gentoo-dev 2014-03-24 14:27:48 UTC
alpha stable
Comment 9 Agostino Sarubbo gentoo-dev 2014-03-24 14:34:35 UTC
ppc64 stable
Comment 10 Agostino Sarubbo gentoo-dev 2014-05-14 16:14:32 UTC
sparc stable.

Maintainer(s), please cleanup.
Security, please vote.
Comment 11 Yury German Gentoo Infrastructure gentoo-dev 2014-06-10 01:04:12 UTC
Arches, Thank you for your work
Maintainer(s), please drop the vulnerable version.

Added to an existing GLSA request.
Comment 12 GLSAMaker/CVETool Bot gentoo-dev 2014-08-19 23:08:07 UTC
CVE-2013-4496 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4496):
  Samba 3.x before 3.6.23, 4.0.x before 4.0.16, and 4.1.x before 4.1.6 does
  not enforce the password-guessing protection mechanism for all interfaces,
  which makes it easier for remote attackers to obtain access via brute-force
  ChangePasswordUser2 (1) SAMR or (2) RAP attempts.
Comment 13 Kristian Fiskerstrand (RETIRED) gentoo-dev 2014-08-31 14:32:23 UTC
No vulnerable packages in 3.6, 4.0 and 4.1 series left in the tree. <3.6 is package masked

# Lars Wendler <polynomial-c@gentoo.org> (14 Mar 2014)
# Masked for security reasons.
# Do NOT remove this mask or the affected packages without speaking to
# bonsaikitten first! You have been warned!
<net-fs/samba-3.6
Comment 14 GLSAMaker/CVETool Bot gentoo-dev 2015-02-26 08:59:14 UTC
This issue was resolved and addressed in
 GLSA 201502-15 at http://security.gentoo.org/glsa/glsa-201502-15.xml
by GLSA coordinator Kristian Fiskerstrand (K_F).