Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 462496 (CVE-2013-0287) - <sys-auth/sssd-1.9.5-r1: "simple_deny_groups" Access Control Bypass Security Issue (CVE-2013-0287)
Summary: <sys-auth/sssd-1.9.5-r1: "simple_deny_groups" Access Control Bypass Security ...
Status: RESOLVED FIXED
Alias: CVE-2013-0287
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Security
URL: https://secunia.com/advisories/52704/
Whiteboard: ~3 [noglsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 15:19 UTC by Agostino Sarubbo
Modified: 2014-05-21 19:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-03-20 15:19:31 UTC
From ${URL} :

Description
A security issue has been reported in SSSD, which can be exploited by malicious users to bypass certain security restrictions.

The security issue is caused due to the application improperly restricting access when the Simple Access Provider is used with the "simple_deny_groups" option 
(/etc/sssd/sssd.conf), which can be exploited to bypass the access control.

Successful exploitation requires that the application is configured to use the Microsoft Active Directory Provider or an equivalent LDAP Provider configuration.

The security issue is reported in versions 1.9.0 and later.


Solution
Fixed in the GIT repository (please see the vendor's advisory for details). A fix is planned to be released in version 1.9.5.

Provided and/or discovered by
The vendor credits Kaushik Banerjee, Red Hat Quality Engineering Team.

Original Advisory
SSSD:
https://lists.fedorahosted.org/pipermail/sssd-devel/2013-March/014066.html

sssd-1-9 GIT:
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=8b8019fe3dd1564fba657e219ec20ff816c7ffdb
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=26590d31f492dbbd36be6d0bde46a4bd3b221edb
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=754b09b5444e6da88ed58d6deaed8b815e268b6b
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=b63830b142053f99bfe954d4be5a2b0f68ce3a93

master GIT:
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=c0bca1722d6f9dfb654ad78397be70f79ff39af1
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=6569d57e3bc168e6e83d70333b48c5cb43aa04c4
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=6837eee3f7f81c0ee454d3718d67d7f3cc6b48ef
http://git.fedorahosted.org/cgit/sssd.git/patch/?id=7619be9f6bf649665fcbeee9e6b120f9f9cba2a5

Red Hat Bug#910938:
https://bugzilla.redhat.com/show_bug.cgi?id=910938
Comment 1 GLSAMaker/CVETool Bot gentoo-dev 2013-03-22 16:26:59 UTC
CVE-2013-0287 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-0287):
  The Simple Access Provider in System Security Services Daemon (SSSD) 1.9.0
  through 1.9.4, when the Active Directory provider is used, does not properly
  enforce the simple_deny_groups option, which allows remote authenticated
  users to bypass intended access restrictions.
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2014-05-20 18:25:54 UTC
What is going on here? 1.9.6 is in the tree for a long time and in the process of stabilization. See 510870
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2014-05-20 18:25:54 UTC
What is going on here? 1.9.6 is in the tree for a long time and in the process of stabilization. See 510870
Comment 4 Yury German Gentoo Infrastructure gentoo-dev 2014-05-21 02:22:02 UTC
(In reply to Markos Chandras from comment #3)
> What is going on here? 1.9.6 is in the tree for a long time and in the
> process of stabilization. See 510870

Thank you for letting us know, and I am going to set this to cleanup mode to clean up the vulnerable packages. From what I see it looks like 1.9.4-r3 might be vulnerable, if the fix was included in 1.9.5-r1. 

Can you confirm this?
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2014-05-21 18:57:46 UTC
(In reply to Yury German from comment #4)
> (In reply to Markos Chandras from comment #3)
> > What is going on here? 1.9.6 is in the tree for a long time and in the
> > process of stabilization. See 510870
> 
> Thank you for letting us know, and I am going to set this to cleanup mode to
> clean up the vulnerable packages. From what I see it looks like 1.9.4-r3
> might be vulnerable, if the fix was included in 1.9.5-r1. 
> 
> Can you confirm this?

According to comment #1, there are four commits in 1.9 branch that fixed that problem back in Feb 2013. The release of 1.9.6 was in 2013-11-06 so I'd say that this is indeed fixed in 1.9.6
According to comment #1 again:
"Fixed in the GIT repository (please see the vendor's advisory for details). A fix is planned to be released in version 1.9.5."

I will write back to this back when the latest 1.9.6 is stabilized and I have removed all the previous ebuilds.
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2014-05-21 19:06:37 UTC
(In reply to Markos Chandras from comment #5)
> (In reply to Yury German from comment #4)
> > (In reply to Markos Chandras from comment #3)
> > > What is going on here? 1.9.6 is in the tree for a long time and in the
> > > process of stabilization. See 510870
> > 
> > Thank you for letting us know, and I am going to set this to cleanup mode to
> > clean up the vulnerable packages. From what I see it looks like 1.9.4-r3
> > might be vulnerable, if the fix was included in 1.9.5-r1. 
> > 
> > Can you confirm this?
> 
> According to comment #1, there are four commits in 1.9 branch that fixed
> that problem back in Feb 2013. The release of 1.9.6 was in 2013-11-06 so I'd
> say that this is indeed fixed in 1.9.6
> According to comment #1 again:
> "Fixed in the GIT repository (please see the vendor's advisory for details).
> A fix is planned to be released in version 1.9.5."
> 
> I will write back to this back when the latest 1.9.6 is stabilized and I
> have removed all the previous ebuilds.

I just realized that 1.8 is not affected so I just dropped anything between 1.9.0 and 1.9.6

+  21 May 2014; Markos Chandras <hwoarang@gentoo.org> -sssd-1.9.4-r3.ebuild,
+  -sssd-1.9.5-r1.ebuild, -sssd-1.9.6-r1.ebuild:
+  Clean up old ebuilds per #462496
+
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-05-21 19:44:33 UTC
No glsa needed. Closed.