Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 290194 (CVE-2009-3627) - <dev-perl/HTML-Parser-3.63: Incorrect entity parsing (CVE-2009-{3626,3627})
Summary: <dev-perl/HTML-Parser-3.63: Incorrect entity parsing (CVE-2009-{3626,3627})
Status: RESOLVED FIXED
Alias: CVE-2009-3627
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Security
URL: https://issues.apache.org/SpamAssassi...
Whiteboard: B3 [noglsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-23 01:55 UTC by Benny Pedersen
Modified: 2010-05-22 11:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benny Pedersen 2009-10-23 01:55:38 UTC
security update as time permit it

Reproducible: Always
Comment 1 Torsten Veller (RETIRED) gentoo-dev 2009-10-23 13:28:39 UTC
dev-perl/HTML-Parser-3.63 is already in the tree.

perl bug: <http://rt.perl.org/rt3/Public/Bug/Display.html?id=69973>
gmane link: <http://article.gmane.org/gmane.comp.lang.perl.perl5.porters/74707>
Comment 2 Tobias Heinlein (RETIRED) gentoo-dev 2009-10-23 17:10:34 UTC
Thanks. My understanding is that only perl-5.10.1 is affected by the crash issue. Can you confirm that our latest stable version of perl is not affected? If yes, we'll stabilize HTML-Parser-3.63 only; if no, we'll have to patch our latest stable perl as well.
Comment 3 Tobias Heinlein (RETIRED) gentoo-dev 2009-10-23 17:14:05 UTC
I wonder if this is actually a security bug at all. Someone else from security, please advise.
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2009-10-27 08:50:43 UTC
(In reply to comment #2)
> My understanding is that only perl-5.10.1 is affected by the crash
> issue. Can you confirm that our latest stable version of perl is not affected?

Yes, no segfault with 5.8.8 and the test script from rt69973.
perl-5.10.1 is fixed too.
Comment 5 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-10-31 19:30:50 UTC
CVE-2009-3627 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3627):
  The decode_entities function in util.c in HTML-Parser before 3.63
  allows context-dependent attackers to cause a denial of service
  (infinite loop) via an incomplete SGML numeric character reference,
  which triggers generation of an invalid UTF-8 character.

Comment 6 Stefan Behte (RETIRED) gentoo-dev Security 2009-11-06 14:18:15 UTC
Patch here:
http://github.com/gisle/html-parser/commit/b9aae1e43eb2c8e989510187cff0ba3e996f9a4c
Comment 7 Stefan Behte (RETIRED) gentoo-dev Security 2009-11-15 21:08:30 UTC
*** Bug 293128 has been marked as a duplicate of this bug. ***
Comment 8 Robert Buchholz (RETIRED) gentoo-dev 2009-11-16 12:30:14 UTC
This is a bug in stable HTML-Parser that triggers a vulnerability in unstable Perl. Since the bug in Perl is being fixed (bug 293128), there is nothing to do on this bug for security.
As a precautionary measure I am adding architectures to stable the latest HTML-Parser release via this bug.
Comment 9 Robert Buchholz (RETIRED) gentoo-dev 2009-11-16 12:40:23 UTC
Arches, please test and mark stable:
=dev-perl/HTML-Parser-3.64
Target keywords : "alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86"
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2009-11-16 19:49:36 UTC
Stable for HPPA.
Comment 11 Markus Meier gentoo-dev 2009-11-16 23:01:48 UTC
amd64/x86 stable
Comment 12 Markus Meier gentoo-dev 2009-11-16 23:18:57 UTC
arm stable
Comment 13 Raúl Porcel (RETIRED) gentoo-dev 2009-11-17 17:11:08 UTC
alpha/ia64/m68k/s390/sh/sparc stable
Comment 14 Brent Baude (RETIRED) gentoo-dev 2009-11-17 17:11:20 UTC
ppc64 done
Comment 15 nixnut (RETIRED) gentoo-dev 2009-11-21 20:04:00 UTC
ppc stable
Comment 16 Torsten Veller (RETIRED) gentoo-dev 2009-11-23 09:05:37 UTC
(In reply to comment #8)
> This is a bug in stable HTML-Parser that triggers a vulnerability in unstable
> Perl. Since the bug in Perl is being fixed (bug 293128), there is nothing to do
> on this bug for security.
> As a precautionary measure I am adding architectures to stable the latest
> HTML-Parser release via this bug.

Latest HTML-Parser is stable for all arches, the old versions were removed. I am closing this bug now.
Comment 17 Tobias Heinlein (RETIRED) gentoo-dev 2010-04-30 17:45:02 UTC
This security bug was accidentally closed a while ago.

I vote NO.
Comment 18 Stefan Behte (RETIRED) gentoo-dev Security 2010-05-22 11:16:06 UTC
No, too. Closing noglsa.