Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 97746

Summary: LINGUAS should be documented in 'man make.conf'
Product: Portage Development Reporter: Mark Purtill <gentoo>
Component: DocumentationAssignee: Portage team <dev-portage>
Status: VERIFIED DUPLICATE    
Severity: normal CC: cilly
Priority: High    
Version: 2.0   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Mark Purtill 2005-07-02 11:15:14 UTC
Several ebuilds require LINGUAS to be set in /etc/make.conf to work (e.g.,
kde-i18n).  So this variable should be documented in the make.conf man page.

Reproducible: Always
Steps to Reproduce:
Comment 1 Kalin KOZHUHAROV 2005-08-06 06:59:42 UTC
Can you be more specific?

What does "require LINGUAS to be set" mean?

What did you do?
What happened?
What did you expect?

The idea of the bugzilla template is to make things clear right from the
beginning. If you have used it, now this MSG would be irrelevant...
Comment 2 Mark Purtill 2005-08-06 14:18:13 UTC
Note that this is not a bug about kde-i18n; it's a bug about the lack of
documentation for LINGUAS.  But here's what happens if LINGUAS is not set and
you try to merge kde-i18n.  (Again, this behavior is fine, especially since the
user has no other way of learning about LINGUAS.)

env LINGUAS= emerge kde-i18n
Calculating dependencies ...done!
>>> emerge (1 of 1) kde-base/kde-i18n-3.4.1 to /
>>> md5 files   ;-) kde-i18n-3.3.2.ebuild
>>> md5 files   ;-) kde-i18n-3.2.3.ebuild
>>> md5 files   ;-) kde-i18n-3.4.1.ebuild
>>> md5 files   ;-) kde-i18n-3.4.2.ebuild
>>> md5 files   ;-) files/digest-kde-i18n-3.2.3
>>> md5 files   ;-) files/digest-kde-i18n-3.3.2
>>> md5 files   ;-) files/kde-i18n-ru-3.3.2-kmplot.diff
>>> md5 files   ;-) files/digest-kde-i18n-3.4.1
>>> md5 files   ;-) files/digest-kde-i18n-3.4.2

 * You must define a LINGUAS environment variable that contains a list
 * of the language codes for which languages you would like to install.
 * Look at the LANGS variable inside the ebuild to see the list of
 * available languages.
 * e.g.: LINGUAS="sv de pt"


!!! ERROR: kde-base/kde-i18n-3.4.1 failed.
!!! Function pkg_setup, Line 35, Exitcode 0
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Comment 3 Jason Stubbs (RETIRED) gentoo-dev 2005-10-23 04:03:03 UTC
LINGUAS is not a portage variable. Please voice your opinion on 
gentoo-dev@gentoo.org with regard to the current obscurity of LINGUAS. 

*** This bug has been marked as a duplicate of 70648 ***
Comment 4 Mark Purtill 2005-10-24 11:08:33 UTC
I'm not a gentoo developer, so posting to that mailing list doesn't seem
appropriate.  In any case, I don't have anything to add:  LINGUAS is required by
some ebuilds, is specially handled by portage, and is completely undocumented. 
Feel free to point developers at this bug.
Comment 5 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-10-24 13:53:43 UTC
(In reply to comment #4)
> I'm not a gentoo developer, so posting to that mailing list doesn't seem
> appropriate.  In any case, I don't have anything to add:  LINGUAS is required by
> some ebuilds, is specially handled by portage, and is completely undocumented. 
> Feel free to point developers at this bug.

Neither am I and I post there all the time, there is a seperate list for only
gentoo developers, regular users posting to gentoo-dev is completely appropriate
provided you are on topic, which in this case is the truth.  If you don't push
for any sort of change, nothing will be done and this bug will not get 'fixed'
in any manner.  No one will start this discussion for you.  LINGUAS is a system
variable just as say, PAGER or PYTHONPATH.  If you believe it requires extra
handling and documentation *somewhere* then post on gentoo-dev and make your case.

Comment 6 Mark Purtill 2005-10-24 14:42:34 UTC
While LINGUAS is not documented in 'man make.conf' (at least, it wasn't last
time I checked), I see it is now documented 
in the localization guide <http://www.gentoo.org/doc/en/guide-localization.xml>
and the development guide
<http://dev.gentoo.org/~plasmaroo/devmanual/general-concepts/use-flags/>.  Since
I don't have time for further discussion, I'm going to close this bug.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-11-21 01:00:20 UTC
*** Bug 113132 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-07-23 19:09:41 UTC
*** Bug 186359 has been marked as a duplicate of this bug. ***