Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 915870

Summary: dev-qt/qt-creator-11.0.3 fails tests (segfault)
Product: Gentoo Linux Reporter: Jonathan Lovelace <kingjon3377>
Component: Current packagesAssignee: Qt Bug Alias <qt>
Status: UNCONFIRMED ---    
Severity: normal CC: ionen, jstein, qt
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: dev-qt:qt-creator-11.0.3:20231016-115035.log.gz

Description Jonathan Lovelace 2023-10-16 23:29:42 UTC
Created attachment 873013 [details]

=dev-qt/qt-creator-11.0.3 fails its test phase for me. Specifically, the test tst_qml_ecmascript7 fails with a segfault. However, the log for that test shows it passing all ten sub-tests, then reporting a segfault after finishing:

50/95 Test: tst_qml_ecmascript7
Command: "/var/tmp/portage/dev-qt/qt-creator-11.0.3/work/qt-creator-opensource-src-11.0.3_build/tests/auto/qml/codemodel/ecmascript7/tst_qml_ecmascript7"
Directory: /var/tmp/portage/dev-qt/qt-creator-11.0.3/work/qt-creator-opensource-src-11.0.3_build/tests/auto/qml/codemodel/ecmascript7
"tst_qml_ecmascript7" start time: Oct 16 10:25 EDT
********* Start testing of tst_Ecmascript *********
Config: Using QtTest library 6.5.2, Qt 6.5.2 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 12.3.1 20230526), gentoo 2.14
PASS   : tst_Ecmascript::initTestCase()
PASS   : tst_Ecmascript::test(super.js)
PASS   : tst_Ecmascript::test(class.js)
PASS   : tst_Ecmascript::test(arrow-functions.js)
PASS   : tst_Ecmascript::test(constructor.js)
PASS   : tst_Ecmascript::test(extends.js)
PASS   : tst_Ecmascript::test(yield.js)
PASS   : tst_Ecmascript::test(let.js)
PASS   : tst_Ecmascript::test(template-strings.js)
PASS   : tst_Ecmascript::cleanupTestCase()
Totals: 10 passed, 0 failed, 0 skipped, 0 blacklisted, 640ms
********* Finished testing of tst_Ecmascript *********
Received signal 11 (SIGSEGV), code 1, for address 0x0000000000000018
         [Non-test] function time: 1ms, total time: 641ms
<end of output>
Test time =   0.68 sec
Test Failed.
"tst_qml_ecmascript7" end time: Oct 16 10:25 EDT
"tst_qml_ecmascript7" time elapsed: 00:00:00
Comment 1 Jonathan Lovelace 2023-10-16 23:30:55 UTC
Created attachment 873014 [details]
Comment 2 Jonathan Lovelace 2023-10-16 23:32:24 UTC
Created attachment 873015 [details]
Comment 3 Ionen Wolkens gentoo-dev 2023-10-17 00:53:45 UTC
Can't reproduce.

62/87 Test #50: tst_qml_ecmascript7 ............................   Passed    0.37 sec
100% tests passed, 0 tests failed out of 87

I tried using Qt6.6.0 though, but it passed fine with Qt6.5.2/.3 too last time I tried given I been running its tests and starting it up with every Qt bumps along other things as a reference for Qt issues (albeit with Qt6.5.2 I think I only tried the older 11.0.2 given 11.0.3 released just after Qt6.5.3 which is still waiting after bug #915549 for stable -- not that 11.0.3 has much changes given bigger things are in qtcreator 12 beta so I doubt it's related).
Comment 4 Jonathan Lovelace 2023-10-19 02:46:23 UTC
I wouldn't be surprised if something about my CFLAGS is related; I have "-fno-unwind-tables -fno-asynchronous-unwind-tables -fomit-frame-pointer" in my CFLAGS, and I have to disable those for luajit, libgsf, and possibly dev-lang/go and libffi to fix test failures. 

I tried doing the same to qt-creator, and the tests passed that time. So maybe one or more of -fno-unwind-tables, -fno-asynchronous-unwind-tables, or -fomit-frame-pointer should be filtered from CFLAGS?
Comment 5 Jonathan Lovelace 2023-11-16 02:33:31 UTC
I just hit this again, rebuilding against Qt 5.15, even with my unusual CFLAGS (-fno-unwind-tables, -fno-asynchronous-unwind-tables, or -fomit-frame-pointer) flipped back ... so while I still suspect there's something in my configuration combined with this particular hardware that's triggering the failure, stripping that uwinding-related information wasn't the sole cause.