Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 728624

Summary: www-client/chromium: segfaults with media-video/ffmpeg-4.3
Product: Gentoo Linux Reporter: Marcin Deranek <marcin.deranek>
Component: Current packagesAssignee: Chromium Project <chromium>
Status: RESOLVED FIXED    
Severity: normal CC: audvare, captaincrutches, che, gentoo, gyakovlev, jbuchert+genbug, jfostiguy, joakim.tjernlund, mgorny, mmk, sam, samuelbernardo.mail, t-mo, voron1
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugs.archlinux.org/task/67020
See Also: https://bugs.gentoo.org/show_bug.cgi?id=738238
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Patch

Description Marcin Deranek 2020-06-18 08:51:29 UTC
When accessing some websites (eg. Google Calendar, Youtube) Chromium segfaults when using ffmpeg-4.3. Downgrading ffmpeg to 4.2.3 makes Chromium work correctly again.
Have a look at included web link to see more details.

Reproducible: Always

Steps to Reproduce:
1. Install chromium-84.0.4147.45 and ffmpeg-4.3
2. Go to Google Calendar or play video on Youtube
Actual Results:  
Aw, Snap! message in Chromium appears.

Expected Results:  
Chromium should show webpage / play video.

Portage 2.3.101 (python 3.7.7-final-0, default/linux/amd64/17.1/desktop, gcc-10.1.0, glibc-2.31-r5, 5.7.3-gentoo x86_64)
=================================================================
System uname: Linux-5.7.3-gentoo-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.7
KiB Mem:    32905792 total,  28682616 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 18 Jun 2020 07:45:01 +0000
Head commit of repository gentoo: e25457c673c2e20cf9e6f4061f6d87a3278a1444
sh bash 5.0_p17
ld GNU ld (Gentoo 2.34 p4) 2.34.0
app-shells/bash:          5.0_p17::gentoo
dev-java/java-config:     2.3::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18::gentoo, 3.7.7-r2::gentoo, 3.8.3::gentoo, 3.9.0_beta3::gentoo
dev-util/cmake:           3.17.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2::gentoo
sys-devel/binutils:       2.34-r1::gentoo
sys-devel/gcc:            10.1.0-r1::gentoo
sys-devel/gcc-config:     2.3::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.31-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.nl.gentoo.org/gentoo-portage/
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1

slonko
    location: /usr/local/portage/local
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O2 -Wl,--as-needed -Wl,-z,now"
LINGUAS="en en_US en_GB nl pl"
MAKEOPTS="-j9"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac accessibility acpi adns alsa amd64 ao atm audiofile ayatana bash-completion berkdb bidi branding bzip2 cairo calendar caps cdda cddb cdr clamav cli cracklib crypt css cups curl cxx dbus dga dri dts dv dvb dvd dvdr encode exif expat fbcon ffmpeg fftw filecaps flac fontconfig ftp gd gdbm geoip geolocation ggi gif gimp glut gmp gnutls gphoto2 gpm graphicsmagick graphviz gstreamer gtk guile gzip hddtemp iconv icu imagemagick imap imlib inotify introspection ipv6 javascript jbig jemalloc jit joystick jpeg jpeg2k lame lcms ldap libass libcaca libffi libnotify libsamplerate libtirpc libwww lua luajit lzma lzo m17n-lib mad maildir matroska mbox mhash mikmod mmap mms mng modplug modules mp3 mp4 mpeg mpi mplayer mtp multilib musepack ncurses nls nntp nocd nptl nsplugin offensive ogg openal opencl openexr opengl openmp orc osc pam pango pch pcre pdf pie plotutils png policykit posix postscript ppds pulseaudio qt5 quicktime raw readline recode scanner sdl seccomp session slang slp smp sndfile snmp sockets sound sox speex spell split-usr ssl startup-notification svg syslog systemd szip taglib tcmalloc tcpd theora threads tidy tiff truetype udev udisks unicode upower usb v4l vaapi vcd vdpau videos vim-syntax vorbis vulkan wavpack webkit webp wmf wxwidgets x264 x265 xcb xcomposite xft xml xmlrpc xmp xmpp xosd xpm xscreensaver xv xvid zip zlib zstd" ABI_X86="32 64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx f16c fma3 fma4 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US en-GB nl pl" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NGINX_MODULES_HTTP="rewrite uwsgi charset lua gzip gzip_static" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7" QEMU_SOFTMMU_TARGETS="x86_64" RUBY_TARGETS="ruby27" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 gentoo@imrebuild.com 2020-06-18 20:15:52 UTC
This problem seems to be related to "av_max_alloc(0)".

https://bugs.chromium.org/p/chromium/issues/detail?id=1095962
Comment 2 Matt Whitlock 2020-06-19 15:33:54 UTC
Could we get an RDEPEND="<media-video/ffmpeg-4.3" in www-client/chromium while this bug is addressed?
Comment 3 Arfrever Frehtes Taifersar Arahesis 2020-06-19 16:43:51 UTC
Created attachment 645264 [details, diff]
Patch

Please install media-video/ffmpeg-4.3 and rebuild www-client/chromium with this patch and check result.
Comment 4 Georgy Yakovlev archtester gentoo-dev 2020-06-19 19:02:43 UTC
confirmed, aw snap error 256 going to youtube on chromium on ppc64le =) I thought it's ppc64 related at first but looks not. trying the patch now.
Comment 5 Georgy Yakovlev archtester gentoo-dev 2020-06-19 20:05:42 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #3)
> Created attachment 645264 [details, diff] [details, diff]
> Patch
> 
> Please install media-video/ffmpeg-4.3 and rebuild www-client/chromium with
> this patch and check result.

this patch helps.

probably patching is better than restricting ffmpeg version.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2020-06-19 20:31:30 UTC
So it's not only me!
Comment 7 Jean-Francois Ostiguy 2020-06-19 22:16:46 UTC
I confirm that the patch cures the issue. Thanks !
Comment 8 Larry the Git Cow gentoo-dev 2020-06-20 04:09:43 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fd3c6eeae58085ad2248e99ad67d8eba0f3a25ff

commit fd3c6eeae58085ad2248e99ad67d8eba0f3a25ff
Author:     Aaron Bauman <bman@gentoo.org>
AuthorDate: 2020-06-20 04:08:29 +0000
Commit:     Aaron Bauman <bman@gentoo.org>
CommitDate: 2020-06-20 04:09:34 +0000

    www-client/chromium: add patch for media alloc fix
    
    Closes: https://bugs.gentoo.org/728624
    Fixed-by: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com>
    Signed-off-by: Aaron Bauman <bman@gentoo.org>

 .../chromium/chromium-84.0.4147.45-r1.ebuild       | 805 +++++++++++++++++++++
 .../chromium/files/chromium-84-mediaalloc.patch    |  41 ++
 2 files changed, 846 insertions(+)
Comment 9 Stephan Hartmann gentoo-dev 2020-06-20 08:21:18 UTC
Patch is wrong for USE=-system-ffmpeg and stable is still affected.
Comment 10 Stephan Hartmann gentoo-dev 2020-06-23 10:44:29 UTC
*** Bug 729182 has been marked as a duplicate of this bug. ***
Comment 11 Stephan Hartmann gentoo-dev 2020-06-23 19:54:29 UTC
*** Bug 729182 has been marked as a duplicate of this bug. ***
Comment 12 Joakim Tjernlund 2020-10-07 16:28:20 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #3)
> Created attachment 645264 [details, diff] [details, diff]
> Patch
> 
> Please install media-video/ffmpeg-4.3 and rebuild www-client/chromium with
> this patch and check result.

hmm, would it not be a good idea to undo the change in ffmpeg-4.3 which requires
this patch to apps?

ffmpeg-4.3 should be ABI compatible with previous ffmpegs