Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 690514

Summary: dev-ruby/regexp_property_values-1.0.0 : * Unable to generate gemspec file.
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Gentoo Ruby Team <ruby>
Status: CONFIRMED ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge-info.txt
dev-ruby:regexp_property_values-1.0.0:20190723-014525.log
emerge-history.txt
environment
etc.portage.tbz2

Description Toralf Förster gentoo-dev 2019-07-23 19:12:19 UTC
 * ERROR: dev-ruby/regexp_property_values-1.0.0::gentoo failed (install phase):
 *   Unable to generate gemspec file.
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20190722-003824

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *




emerge -qpvO dev-ruby/regexp_property_values
[ebuild  N    ] dev-ruby/regexp_property_values-1.0.0  USE="-doc -test" RUBY_TARGETS="ruby24 -ruby25 -ruby26"
Comment 1 Toralf Förster gentoo-dev 2019-07-23 19:12:22 UTC
Created attachment 584180 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-23 19:12:25 UTC
Created attachment 584182 [details]
dev-ruby:regexp_property_values-1.0.0:20190723-014525.log
Comment 3 Toralf Förster gentoo-dev 2019-07-23 19:12:28 UTC
Created attachment 584184 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-07-23 19:12:31 UTC
Created attachment 584186 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-07-23 19:12:33 UTC
Created attachment 584188 [details]
etc.portage.tbz2
Comment 6 Hans de Graaff gentoo-dev 2019-07-26 06:01:36 UTC
It looks like you are not running a UTF-8 locale?
Comment 7 Toralf Förster gentoo-dev 2019-07-26 16:56:42 UTC
(In reply to Hans de Graaff from comment #6)
> It looks like you are not running a UTF-8 locale?

indeed, was set to POSIX- will fix it here