Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 690300

Summary: RUBY_TARGETS ignored in /etc/portage/profile/make.profile
Product: Gentoo Linux Reporter: Ciprian Ciubotariu <cheepeero>
Component: EclassesAssignee: Gentoo Ruby Team <ruby>
Status: RESOLVED FIXED    
Severity: normal CC: fedeliallalinea
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Ciprian Ciubotariu 2019-07-20 17:47:21 UTC
I have a shared git repo containing profile/make.defaults across multiple hosts, with local customizations in make.conf. After the upgrade today ruby packages no longer obey the RUBY_TARGETS setting in profile/make.defaults, and as a workaround I placed this in make.conf. I would still want this fixed to avoid inconsistency (for instance, PYTHON_TARGETS is working just fine)

Reproducible: Always

Steps to Reproduce:
pink /etc/portage # grep RUBY_TARGETS make.conf profile/make.defaults 
profile/make.defaults:RUBY_TARGETS="ruby24"
pink /etc/portage # emerge -qav vagrant

emerge: there are no ebuilds to satisfy "<dev-ruby/mime-types-3:*[ruby_targets_ruby25]".
(dependency required by "app-emulation/vagrant-2.2.5::gentoo[-test,ruby_targets_ruby25]" [ebuild])
(dependency required by "vagrant" [argument])
pink /etc/portage # echo 'RUBY_TARGETS="ruby24"' >> make.conf
pink /etc/portage # emerge -qav vagrant
[ebuild  N    ] virtual/ruby-ssl-10  RUBY_TARGETS="ruby24 (-ruby25)" 
....
Comment 1 Hans de Graaff gentoo-dev 2019-07-22 06:38:37 UTC
*** Bug 690428 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2019-07-22 06:40:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=44eed74d8bc1287470555ae21ca5531782a5185d

commit 44eed74d8bc1287470555ae21ca5531782a5185d
Author:     Hans de Graaff <graaff@gentoo.org>
AuthorDate: 2019-07-22 06:38:01 +0000
Commit:     Hans de Graaff <graaff@gentoo.org>
CommitDate: 2019-07-22 06:38:01 +0000

    profiles/arch: turn off ruby25 in RUBY_TARGETS
    
    This is needed to overrule the ruby25 target in the base make.defaults.
    Otherwise this ruby target will be set for all stable profiles without
    ruby itself being stable.
    
    Fixes: https://bugs.gentoo.org/690300
    
    Signed-off-by: Hans de Graaff <graaff@gentoo.org>

 profiles/arch/alpha/make.defaults         | 2 +-
 profiles/arch/amd64/make.defaults         | 2 +-
 profiles/arch/arm/make.defaults           | 2 +-
 profiles/arch/arm64/make.defaults         | 2 +-
 profiles/arch/hppa/make.defaults          | 2 +-
 profiles/arch/ia64/make.defaults          | 2 +-
 profiles/arch/powerpc/ppc32/make.defaults | 2 +-
 profiles/arch/powerpc/ppc64/make.defaults | 2 +-
 profiles/arch/s390/make.defaults          | 2 +-
 profiles/arch/sparc/make.defaults         | 2 +-
 profiles/arch/x86/make.defaults           | 2 +-
 11 files changed, 11 insertions(+), 11 deletions(-)