Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690428 - ruby_targets_ruby25 is enabled in stable amd64 profile
Summary: ruby_targets_ruby25 is enabled in stable amd64 profile
Status: RESOLVED DUPLICATE of bug 690300
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Profiles (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-22 05:29 UTC by Marco Genasci
Modified: 2019-07-23 05:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Genasci 2019-07-22 05:29:47 UTC
In a stable profile default ruby targets are RUBY_TARGETS="ruby24 ruby25", this cause problem when a user unmask a unstable package how ruby25 use flag isn't masked. In my case I unmasked dev-ruby/compass-1.0.3-r1 but when I try to update system I get 

emerge: there are no ebuilds to satisfy ">=dev-ruby/rb-inotify-0.9[ruby_targets_ruby25]".
(dependency required by "dev-ruby/compass-1.0.3-r1::gentoo[-test,ruby_targets_ruby25]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

As workaround I added in make.conf RUBY_TARGETS="ruby24"

Reproducible: Always
Comment 1 Hans de Graaff gentoo-dev 2019-07-22 06:38:37 UTC

*** This bug has been marked as a duplicate of bug 690300 ***