Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 663834

Summary: dev-util/nvidia-cuda-toolkit should not require x11-drivers/nvidia-drivers to be built with X use flag
Product: Gentoo Linux Reporter: Nathaniel Lewis <linux.robotdude>
Component: Current packagesAssignee: Gentoo Science Related Packages <sci>
Status: UNCONFIRMED ---    
Severity: normal CC: chutzpah, liam
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 663830    
Bug Blocks:    
Attachments: patch demonstrating change
patch demonstrating change
patch demonstrating change

Description Nathaniel Lewis 2018-08-17 01:13:57 UTC
Created attachment 543748 [details, diff]
patch demonstrating change

depends on: https://bugs.gentoo.org/663830

the patch above removes the requirement of the X use flag to be set to install the cuda library from nvidia-drivers.

With this patch, nvidia-cuda-toolkit doesn't need to require nvidia-drivers to be built with X support anymore.  This patch makes the change to the dependencies.  The overall goal here being to have an X-less nvidia cuda install for headless systems.
Comment 1 Nathaniel Lewis 2018-08-23 21:06:56 UTC
Created attachment 544708 [details, diff]
patch demonstrating change
Comment 2 Nathaniel Lewis 2018-08-23 21:24:14 UTC
Confirmed that both CUDA and OpenCL works on with this patch.
Comment 3 Nathaniel Lewis 2018-08-23 21:28:00 UTC
Created attachment 544728 [details, diff]
patch demonstrating change

attached wrong patch
Comment 4 Marius Brehler 2018-08-24 07:47:33 UTC
(In reply to Nathaniel Lewis from comment #2)
> Confirmed that both CUDA and OpenCL works on with this patch.

Have re-emerged nvidia-drivers without X?
Comment 5 Nathaniel Lewis 2018-08-26 02:44:16 UTC
> Have re-emerged nvidia-drivers without X?

Correct.  Having re-emerged nvidia-drivers without X with the associated nvidia-drivers patch.